Bug 1021323 - Gnome Tweak Tool has limited ability to configure font hinting and font preferences
Gnome Tweak Tool has limited ability to configure font hinting and font prefe...
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: gnome-tweak-tool (Show other bugs)
19
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Mohamed El Morabity
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 01:30 EDT by Maxwell Spangler
Modified: 2015-02-17 12:45 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 12:45:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of gnome-tweak-tool settings, what works and what doesn't (701.21 KB, image/png)
2013-10-21 01:30 EDT, Maxwell Spangler
no flags Details
packages updated during yum update (10.99 KB, text/plain)
2013-10-21 01:36 EDT, Maxwell Spangler
no flags Details
full list of all installed packages on my system (58.19 KB, text/plain)
2013-10-21 01:36 EDT, Maxwell Spangler
no flags Details

  None (edit)
Description Maxwell Spangler 2013-10-21 01:30:26 EDT
Created attachment 814400 [details]
Screenshot of gnome-tweak-tool settings, what works and what doesn't

Description of problem:
After a perodic 'yum update' to my Fedora 19 system last night, I noticed that many applications have stopped using the font choices that I set for them using gnome-tweak-tool.

For example, I replace Cantarell with Lucida Grande for Default Font and Document Font.  When I run Evolution now, the list of folders and messages is in Cantarell and I can't change it.  However, the individual message preview sub-window that shows from/to/subject responds to my gtt default font setting.  The message body preview responds to my gtt Document font setting.

So what I've lost is Evolution other gtk based apps following Default font and Document for much of their content.

Attempts to use gnome-tweak-tool to change font hinting would normally show visible stair-stepping if set to "None" and smooth fonts if set to slight or medium.  Hinting now has no impact on any fonts.  The GTT Antialiasing setting also appears to have no impact.

Version-Release number of selected component (if applicable):
Fedora 19, updated 10/20/2013.  I'll attach a list of the packages involved in the update although I don't know which package(s) are involved in this bug/change.

How reproducible:
Works on my single system with my normal user account and with an optional, clean "guest" account.

Steps to Reproduce:
1.  Update to current 10/20/2013 packages
2.  Attempt to change fonts with gnome-tweak-tool
3.  Observe results with Evolution and other gtk applications.

Actual results:
GTT is still properly changing configuration settings but its effectiveness is being lost as applications don't seem to be following those settings.

Expected results:
GTT should be able to allow users to change old and new settings in GNOME so that "Document font" can effectively be set by the user to control their environment.

Additional info:
If changes in the back end of gnome font handling are moving away from GTT's configuration variables, can we please have a documented way to change these settings otherwise?
Comment 1 Maxwell Spangler 2013-10-21 01:36:23 EDT
Created attachment 814401 [details]
packages updated during yum update

This file contains the /var/log/yum.log lines from the package update performed on my system last night.  After last night's update, my font handling changed.  I don't know which package is suspect.
Comment 2 Maxwell Spangler 2013-10-21 01:36:56 EDT
Created attachment 814402 [details]
full list of all installed packages on my system
Comment 3 Fedora End Of Life 2015-01-09 15:19:30 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 4 Adam Williamson 2015-02-09 16:01:50 EST
Are you sure this was "and other GTK apps", or did you only check Evolution?

Something I ran into today suggests to me that Evolution *specifically* doesn't respect the GTT settings:

https://www.happyassassin.net/2015/02/09/font-oddities-dejavu-sans-mono-hinting-gnome-and-evolution/

but other apps - gedit, GNOME Terminal, even Firefox! - do, for me.
Comment 5 Fedora End Of Life 2015-02-17 12:45:59 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.