Bug 1021343 - [RHSC] - Stop rebalance confirmation dialog does not display the volumes on which rebalance is going to be stopped.
[RHSC] - Stop rebalance confirmation dialog does not display the volumes on w...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: Timothy Asir
RamaKasturi
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 02:47 EDT by RamaKasturi
Modified: 2015-05-13 12:28 EDT (History)
7 users (show)

See Also:
Fixed In Version: cb9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:41:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Current stop rebalance confirmation dialog (190.58 KB, image/png)
2013-11-26 04:06 EST, RamaKasturi
no flags Details
Stop volume confirmation popup (195.32 KB, image/png)
2013-11-26 04:06 EST, RamaKasturi
no flags Details
Screen shot from cb10 build . (196.86 KB, image/png)
2013-12-10 07:22 EST, RamaKasturi
no flags Details

  None (edit)
Description RamaKasturi 2013-10-21 02:47:12 EDT
Description of problem:
 Stop rebalance confirmation dialog does not display the volumes on which rebalance  is going to be stopped.

Version-Release number of selected component (if applicable):
rhsc-2.1.2-0.0.scratch.beta1.el6_4.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create a volume and start rebalance on the volume.
2. Once rebalance is started click on the status dialog from the drop down menu.
3. Now click on the stop rebalance dialog .
4. Now it opens a confirmation dialog for stop rebalance.

Actual results:
In the cofirmation dialog it has the following text "Are you sure you want to stop the rebalance operation in following Volume(s)?"

Expected results:
With the text above it should display the volName on which rebalance is going to be stopped.

Additional info:
Comment 2 Dusmant 2013-10-24 02:41:06 EDT
Make the text as "Are you sure you want to stop the rebalance operation on following Volume : <volume-name>?"
Comment 3 RamaKasturi 2013-11-26 04:03:24 EST
stop rebalance confirmation dialog is not consistent with other "stop" dialogs.

Attaching the current "stop rebalance confirmation dialog" and the correct "stop dialog screenshots".
Comment 4 RamaKasturi 2013-11-26 04:06:04 EST
Created attachment 829115 [details]
Current stop rebalance confirmation dialog
Comment 5 RamaKasturi 2013-11-26 04:06:54 EST
Created attachment 829116 [details]
Stop volume confirmation popup
Comment 6 Timothy Asir 2013-11-27 00:49:35 EST
This stop rebalance dialog is for a particular volume where as the stop volume confirmation popup is for a set of volumes. So how can we compare this with the one which shows multiple volume confirmation?
Comment 7 RamaKasturi 2013-11-27 01:27:18 EST
Hi Tim,

What I am referring to is, the difference in the way the confirmation question appears on the dialog. Looking at the two screenshots that I have attached, it is clear that, the stop rebalance confirmation is different from other confirmation dialogs seen in the UI. 

The confirmation for stop volume, stop remove-brick etc., appears in the following way - 

"Are you sure you want to stop the rebalance operation on following Volume?"

- <volume-name>?

For stop rebalance, it appears as follows - 

"Are you sure you want to stop the rebalance operation on following Volume : <volume-name>?"

Any reason for this being different from the others?
Comment 8 Timothy Asir 2013-11-27 01:55:09 EST
The attached screen shows: "Are you sure you want to stop the rebalance operation on the volume: <volume Name> ?

The reason is: This message is for a specific volume. As per the current design,
we can not operate stop rebalance for a set of volume like other stop operations.
So we can not (/need not) shows any list of volumes here!
That is why I removed the word "following" and the message comes with a single volume name.
Comment 9 RamaKasturi 2013-11-27 02:10:53 EST
Tim,

  It does not matter whether it is a single or multiple volumes. It should be consistent with all the other confirmation dialog in the console.
Comment 10 Dusmant 2013-12-03 13:13:10 EST
The current message is fine and lets not discuss it any further and waste time on this. Pls. move it to ON_QA.
Comment 11 RamaKasturi 2013-12-10 07:19:41 EST
verified in cb10 (rhsc-2.1.2-0.26.master.el6_5.noarch). Now the status dialog displays the volume name on which rebalance is going to be stopped. Attaching the screenshot for the same.
Comment 12 RamaKasturi 2013-12-10 07:22:11 EST
Created attachment 834722 [details]
Screen shot from cb10 build .
Comment 14 errata-xmlrpc 2014-02-25 02:41:25 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.