Bug 1021380 - There is no exit code when adding login to domain meets max member limit
There is no exit code when adding login to domain meets max member limit
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: REST API (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Ravi Sankar
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 04:10 EDT by Meng Bo
Modified: 2015-05-14 20:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 22:25:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2013-10-21 04:10:08 EDT
Description of problem:
Modify the max_members_per_resource to 3 in development.rb file and restart broker service.
Try to add more than 3 members to the domain via RESTAPI.

It will return proper message but do not have exit code.

  <messages>
    <message>
      <severity>error</severity>
      <text>The members could not be added due to validation errors.</text>
      <exit-code nil="true"></exit-code>
      <field nil="true"></field>
      <index nil="true"></index>
    </message>
  </messages>


Version-Release number of selected component (if applicable):
devenv_3921

How reproducible:
always

Steps to Reproduce:
1. Set the max_members_per_resource
2. Restart broker and clear broker cache
3. Try to add member to the domain more than the limit

Actual results:
No exit code for the operation.

Expected results:
Should have exit code.

Additional info:
Comment 2 Dan McPherson 2013-11-11 18:45:33 EST
exit code should be 222 and the message should be more detailed now.

https://github.com/openshift/origin-server/pull/4166
Comment 4 Meng Bo 2013-11-12 05:18:19 EST
  <messages>
    <message>
      <severity>error</severity>
      <text>You are limited to 2 members per domain</text>
      <exit-code>222</exit-code>
      <field>members</field>
      <index nil="true"></index>
    </message>
  </messages>


Issue has been fixed on devenv_4022.

Note You need to log in before you can comment on or make changes to this bug.