Bug 1021391 - Installer should use English text if no translation is available.
Installer should use English text if no translation is available.
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Installer (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity urgent
: ER7
: EAP 6.2.0
Assigned To: Francisco Canas
Petr Kremensky
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 04:33 EDT by Petr Kremensky
Modified: 2014-09-03 00:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:55:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Kremensky 2013-10-21 04:33:57 EDT
Description of problem:
We still have problem with installer once we miss some translated texts. There are three cases for missing property:
 - installer will show property's id
 - installer won't show any text
 - installer will stuck
We should force installer to use English text once translation is not available to avoid these situations.

Version-Release number of selected component (if applicable):
 EAP 6.2.0.ER6

How reproducible:
 always

Steps to Reproduce:
 1. Run gui installation, use Deutsch. Skip into post-install configuration screen using default values.
 2. On post-install screen select to install Password-Vault.
 3. Enter "test" string into Iterationszählung input text field and press Next (Weiter) button.

Actual results:
 - installer will stuck

Expected results:
 - Error dialog is thrown with English string

Additional info:
 - see BZ1007833 for installer translations status
 - we did something similar for logging see JBPAPP6-820
Comment 1 Francisco Canas 2013-10-22 10:04:39 EDT
The hanging issue described above was actually caused by a separate bug in izpack. It's fix will be present in the next ER.

Additionally, I've now modified izpack to use a 'fallback' langpack when a string can't be found in the user-selected langpack. For the installer the fallback will be english. 

See: 
http://git.app.eng.bos.redhat.com/izpack.git/commit/?id=77c66e36507794ac4c70ea0f25559e906ea3bfa5
Comment 2 Petr Kremensky 2013-11-01 10:19:53 EDT
Verified on EAP 6.2.0.ER7 installer.

Installer will now use English when translated string is missing.

Greate job!

Note You need to log in before you can comment on or make changes to this bug.