Bug 1021410 - Fedora 20: Error while installing F20 using VNC
Fedora 20: Error while installing F20 using VNC
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
ppc64 All
unspecified Severity urgent
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 05:11 EDT by IBM Bug Proxy
Modified: 2013-11-23 23:00 EST (History)
10 users (show)

See Also:
Fixed In Version: pykickstart-1.99.46-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-23 23:00:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log files from /tmp directory after crash (38.25 KB, application/x-gzip)
2013-10-21 05:11 EDT, IBM Bug Proxy
no flags Details
anaconda-tb-kCUntD log file from /tmp directory (62.46 KB, text/plain)
2013-10-21 05:11 EDT, IBM Bug Proxy
no flags Details
anaconda-yum.conf log file from /tmp directory (351 bytes, text/plain)
2013-10-21 05:12 EDT, IBM Bug Proxy
no flags Details
anaconda.log file from /tmp directory (2.49 KB, text/plain)
2013-10-21 05:12 EDT, IBM Bug Proxy
no flags Details
ifcfg.log file from /tmp directory (478 bytes, text/plain)
2013-10-21 05:12 EDT, IBM Bug Proxy
no flags Details
packaging.log from /tmp directory (412 bytes, text/plain)
2013-10-21 05:12 EDT, IBM Bug Proxy
no flags Details
program.log from /tmp directory (20.13 KB, text/plain)
2013-10-21 05:13 EDT, IBM Bug Proxy
no flags Details
storage.log from /tmp directory (77.10 KB, text/plain)
2013-10-21 05:13 EDT, IBM Bug Proxy
no flags Details
syslog from /tmp directory (41.12 KB, text/plain)
2013-10-21 05:13 EDT, IBM Bug Proxy
no flags Details
vncserver.log from /tmp directory (2.94 KB, text/plain)
2013-10-21 05:13 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 98475 None None None Never

  None (edit)
Description IBM Bug Proxy 2013-10-21 05:11:22 EDT
Problem Description
----------------------------------
I am getting below error while installing F20 using vnc. This is coming on pre release ISO (RC4.4). "http://ppc.koji.fedoraproject.org/stage/f20-20131007-RC4.4/Fedora/ppc64/iso/"
------------------------------------------------------
anaconda 20.18-1 for Fedora 20-Alpha (pre-release) started.
16:47:49 Starting VNC...
16:48:36 The VNC server is now running.
16:48:36 

WARNING!!! VNC server running with NO PASSWORD!
You can use the vncpassword=<password> boot option
if you would like to secure the server.

16:48:36 Please manually connect your vnc client to jupiterioc-lp2.austin.ibm.com:1 (9.3.191.121:1) to begin the install.
error: XDG_RUNTIME_DIR not set in the environment.
[xcb] Unknown request in queue while dequeuing
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
python: xcb_io.c:179: dequeue_pending_request: Assertion `!xcb_xlib_unknown_req_in_deq' failed.

Pane is dead
Pane is dead
----------------------------------------------------------

Steps to reproduce:
---------------------------------
1) Create virtual DVD setup using above ISO.
2) Trigger a installation & perform static network & vnc settings by adding boot parameters to grub command line. Below was the command line parameters I used:

linux /ppc/ppc${2}/vmlinuz ro ip=9.3.191.121::9.3.191.1:255.255.254.0:jupiterioc-lp2.austin.ibm.com:eth0:none nameserver=9.0.7.1 inst.noipv6 inst.vnc                                           
initrd /ppc/ppc${2}/initrd.img 

3) Now trigger the installation.
4) You will get above mentioned error after vncserver gets started.
5) I tried connecting to the machine using Tigervnc & vncviewer (using IP:1) but the vnc window was not getting opened.
6) I tried getting more log information using "ctrl+b 2" but nothing happened on console.


== Comment: # - Khushboo Srivastava <khusriva@in.ibm.com> -  ==
I am also seeing this issue on P7 JunoIOXC1. as soon as it is starting the VNC server it is giving Pane dead 
On connecting to the vnc IP:1 I am seeing a black screen.

WARNING!!! VNC server running with NO PASSWORD!
You can use the vncpassword=<password> boot option
if you would like to secure the server.


09:47:46 Please manually connect your vnc client to juno-ioxc1-lp2.austin.ibm.com:1 (9.3.192.132:1) to begin the install.
error: XDG_RUNTIME_DIR not set in the environment.
[xcb] Unknown request in queue while dequeuing
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
python: xcb_io.c:179: dequeue_pending_request: Assertion `!xcb_xlib_unknown_req_in_deq' failed.


Pane is dead


Pane is dead

****************************************

I tried this on two different lpars of the same machine but found the same error.

== Comment: #- Shubham Goyal <shubgoya@in.ibm.com> -==
I believe anaconda should automatically handle this. This authentication shouldn't require user's intervention. I have never seen this in other distributions.
Comment 1 IBM Bug Proxy 2013-10-21 05:11:37 EDT
Created attachment 814479 [details]
log files from /tmp directory after crash
Comment 2 IBM Bug Proxy 2013-10-21 05:11:52 EDT
Created attachment 814480 [details]
anaconda-tb-kCUntD log file from /tmp directory
Comment 3 IBM Bug Proxy 2013-10-21 05:12:10 EDT
Created attachment 814481 [details]
anaconda-yum.conf log file from /tmp directory
Comment 4 IBM Bug Proxy 2013-10-21 05:12:23 EDT
Created attachment 814482 [details]
anaconda.log file from /tmp directory
Comment 5 IBM Bug Proxy 2013-10-21 05:12:40 EDT
Created attachment 814483 [details]
ifcfg.log file from /tmp directory
Comment 6 IBM Bug Proxy 2013-10-21 05:12:55 EDT
Created attachment 814484 [details]
packaging.log from /tmp directory
Comment 7 IBM Bug Proxy 2013-10-21 05:13:08 EDT
Created attachment 814485 [details]
program.log from /tmp directory
Comment 8 IBM Bug Proxy 2013-10-21 05:13:26 EDT
Created attachment 814486 [details]
storage.log from /tmp directory
Comment 9 IBM Bug Proxy 2013-10-21 05:13:39 EDT
Created attachment 814487 [details]
syslog from /tmp directory
Comment 10 IBM Bug Proxy 2013-10-21 05:13:58 EDT
Created attachment 814488 [details]
vncserver.log from /tmp directory
Comment 11 IBM Bug Proxy 2013-10-21 09:33:49 EDT
------- Comment From gusld@br.ibm.com 2013-10-21 13:25 EDT-------
Let me clarify what is being asked here. For some reason, Anaconda tries to contact geoip.fedoraproject.org. The problem is that we have an authenticated proxy server internally that is presenting an authentication form instead of the expected content from geoip.fedoraproject.org. This causes an Anaconda crash.

Anaconda should handle more graciously unexpected content from geoip.fedoraproject.org, either recovering and moving on in case that content is optional, or presenting an error message to the user in case the content from geoip.fedoraproject.org is not optional.
Comment 12 David Shea 2013-10-21 12:03:01 EDT
Added a check for the exception from the JSON decoder. In this case, anaconda will note the error in the log file and continue without GeoIP data.
Comment 13 Fedora Update System 2013-10-21 20:31:56 EDT
anaconda-20.25.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.25.2-1.fc20
Comment 14 Fedora Update System 2013-10-22 14:52:26 EDT
Package anaconda-20.25.2-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-20.25.2-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19692/anaconda-20.25.2-1.fc20
then log in and leave karma (feedback).
Comment 15 IBM Bug Proxy 2013-11-13 11:22:09 EST
------- Comment From shubgoya@in.ibm.com 2013-11-13 16:12 EDT-------
I checked with latest Beta release & didn't get this issue. I believe its fixed in recently released Beta drop.

Kernel version - 3.11.6-301.fc20.ppc64
Anaconda version - anaconda-20.25.6-1.fc20.ppc64.rpm

Thanks for working on this issue...

--Shubham
Comment 16 Fedora Update System 2013-11-15 21:12:57 EST
anaconda-20.25.8-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.25.8-1.fc20
Comment 17 Fedora Update System 2013-11-23 23:00:27 EST
pykickstart-1.99.46-1.fc20, python-blivet-0.23.5-1.fc20, anaconda-20.25.9-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.