Bug 1021449 - ptp: ptp4l didn't work as expect when changing the clockClass at slave
ptp: ptp4l didn't work as expect when changing the clockClass at slave
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: linuxptp (Show other bugs)
6.5
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Miroslav Lichvar
Zhang Kexin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 06:22 EDT by Dong Zhu
Modified: 2014-03-16 21:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-21 21:06:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dong Zhu 2013-10-21 06:22:47 EDT
Description of problem:

change the clockClass to 120
change the priority1 to 255
           priority2 to 255

master:
# ptp4l -i eth1 -f /etc/ptp4l.conf -m
ptp4l[516706.308]: selected /dev/ptp4 as PTP clock
ptp4l[516706.325]: port 1: INITIALIZING to LISTENING on INITIALIZE
ptp4l[516706.326]: port 0: INITIALIZING to LISTENING on INITIALIZE
ptp4l[516712.325]: port 1: LISTENING to MASTER on ANNOUNCE_RECEIPT_TIMEOUT_EXPIRES
ptp4l[516712.325]: selected best master clock 90e2ba.fffe.29bfcc
ptp4l[516712.325]: assuming the grand master role
ptp4l[516715.717]: port 1: new foreign master 90e2ba.fffe.29c0c4-1

slave:
# ptp4l -i eth1 -f /etc/ptp4l.conf -m
ptp4l[354096.689]: selected /dev/ptp4 as PTP clock
ptp4l[354096.695]: port 1: INITIALIZING to LISTENING on INITIALIZE
ptp4l[354096.696]: port 0: INITIALIZING to LISTENING on INITIALIZE
ptp4l[354102.695]: port 1: LISTENING to MASTER on ANNOUNCE_RECEIPT_TIMEOUT_EXPIRES
ptp4l[354102.696]: selected best master clock 90e2ba.fffe.29c0c4
ptp4l[354102.696]: assuming the grand master role
ptp4l[354103.305]: port 1: new foreign master 90e2ba.fffe.29bfcc-1
ptp4l[354107.305]: selected best master clock 90e2ba.fffe.29bfcc
ptp4l[354107.305]: port 1: MASTER to PASSIVE on RS_PASSIVE

slave seems stuck for a long time and no any reflection here.

Version-Release number of selected component (if applicable):
linuxptp-1.3-1.el6.x86_64

How reproducible:
100%
Comment 1 Miroslav Lichvar 2013-10-21 06:41:03 EDT
It seems to be working as expected. Clocks with clockClass smaller than 128 enter the passive state instead of slave.

What output do you expect?

Note You need to log in before you can comment on or make changes to this bug.