Bug 1021456 - qpid-cpp-client yum update fails
qpid-cpp-client yum update fails
Status: CLOSED DUPLICATE of bug 1010999
Product: Fedora
Classification: Fedora
Component: qpid-cpp (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Darryl L. Pierce
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 06:41 EDT by morgan read
Modified: 2015-06-21 20:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-22 07:31:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description morgan read 2013-10-21 06:41:25 EDT
Description of problem:
yum fails to update with error:
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
       
         1. You have an upgrade for qpid-cpp-client which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of qpid-cpp-client of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude qpid-cpp-client.otherarch ... this should give you an error
            message showing the root cause of the problem.
       
         2. You have multiple architectures of qpid-cpp-client installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
       
         3. You have duplicate versions of qpid-cpp-client installed already.
            You can use "yum check" to get yum show these errors.
       
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
       
       Protected multilib versions: qpid-cpp-client-0.18-6.fc18.i686 != qpid-cpp-client-0.24-3.fc18.1.x86_64
Error: Protected multilib versions: qpid-qmf-0.18-6.fc18.i686 != qpid-qmf-0.24-3.fc18.1.x86_64


Version-Release number of selected component (if applicable):
qpid-cpp-client-0.18-6.fc18.i686

How reproducible:
Always

Steps to Reproduce:
1. yum update
2.
3.

Actual results:
Yum update fails

Expected results:
Yum update succeeds

Additional info:
Tried to un-install qpid-cpp-client etc and re-install, but same error
Comment 1 Darryl L. Pierce 2013-10-22 07:31:57 EDT
Please also uninstall qpid-qmf and re-install.

*** This bug has been marked as a duplicate of bug 1010999 ***

Note You need to log in before you can comment on or make changes to this bug.