Bug 1021487 - org.jboss.as.test.integration.mgmt.access.CliInterfaceStandardRolesBasicTestCase sometimes hang on running on Windows OracleJDK16
org.jboss.as.test.integration.mgmt.access.CliInterfaceStandardRolesBasicTestC...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Testsuite (Show other bugs)
6.2.0
Unspecified Windows
unspecified Severity medium
: ER7
: EAP 6.2.0
Assigned To: Ladislav Thon
Pavel Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 07:46 EDT by Pavel Jelinek
Modified: 2013-12-15 11:18 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:18:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-1458 Major Resolved Allow specifying timeout for org.jboss.as.arquillian.container.ManagementClient.isServerInRunningState() 2013-11-26 08:42:21 EST

  None (edit)
Comment 1 Ladislav Thon 2013-10-21 10:46:02 EDT
It's highly unlikely that this particular test case hangs just by itself. Looking at the output, it's more like the previous test case (AccessConstraintUtilizationTestCase) that failed didn't tear down correctly.

Will look into it. Given that I wrote the test, this is devel_ack+ as far as I'm concerned. Can't do that for real, obviously :-)
Comment 2 Ladislav Thon 2013-10-22 06:07:49 EDT
OK, I was wrong, I didn't write AccessConstraintUtilizationTestCase. But I'll still look into it.
Comment 3 Ladislav Thon 2013-10-22 07:10:34 EDT
OK, so here's what's going on. In both cases, some other test failed to tear down correctly. This can be inferred from:

1. Looking at failing tests that precede the RBAC TS. In both cases, IIOP tests fail because some other server is running and they have Arquillian configured to disallow this situation. The error messages in IIOP tests are pretty clear about this.

2. Looking at the failing test in the RBAC TS in second case. The test fails because it can't find a management resource /core-service=management/access=authorization/constraint=sensitivity-classification/type=messaging -- this can only happen when the server doesn't have the messaging subsystem. The RBAC TS uses standalone-full profile, which has messaging enabled, so there must be some server already running in wrong profile.

The purpose of this bug is for the CliInterfaceStandardRolesBasicTestCase test to fail fast and not try to wait indefinitely for something that's not gonna happen.
Comment 4 Ladislav Thon 2013-10-23 08:50:42 EDT
I'm not sure if I found the same problem that caused this issue, but I did find an error in the implementation of Arquillian managed container in WildFly/EAP. In certain situations, similar to this one, the container startup timeout is prolonged cca 50x (default is 1 minute, so in the erroneous situation, it's 50 wasted minutes). Need to work on it upstream, not sure about hitting/missing 6.2.
Comment 5 Ladislav Thon 2013-10-23 09:20:43 EDT
Linking an upstream JIRA that I believe is essentially the same problem: https://issues.jboss.org/browse/WFLY-1458
Comment 9 Pavel Jelinek 2013-11-11 06:22:19 EST
This issue was not spotted in EAP 6.2.0.ER7.

Note You need to log in before you can comment on or make changes to this bug.