Bug 1021488 - org.jboss.as.test.xts.simple.wsat.client.WSATTestCase sometimes hang on
org.jboss.as.test.xts.simple.wsat.client.WSATTestCase sometimes hang on
Status: CLOSED DUPLICATE of bug 1021486
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Testsuite, XTS (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Gytis Trikleris
Pavel Jelinek
:
Depends On: 1021486
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 07:46 EDT by Pavel Jelinek
Modified: 2014-10-25 08:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-25 06:41:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Paul Robinson 2013-10-22 11:09:24 EDT
We've had several issues like this where an XTS test hangs. Our CI is showing that we've fixed all (or most) of these hangs. It's possible that we have neglected to backport one of them.

I have asked Gytis Trikleris (gytis@redhat.com) to investigate.

What I can say is that all the XTS test hangs that we have found to date have been due to bugs in the tests rather than the actual code. So, although annoying for us, I don't think this has much of a customer impact.
Comment 2 Paul Robinson 2013-10-22 11:13:34 EDT
Also,

How frequently is this happening? Has it happened more than once?

Can you do a "kill -3" on all java processes next time? We really need to see what the threads were doing at the time of the hang.
Comment 3 Gytis Trikleris 2013-10-23 09:51:12 EDT
I have failed to reproduce the issue locally. Therefore, I agree with Paul, additional information would be helpful.

Additionally, based on the git history, Ondrej removed the failing test with the next commit.
Comment 4 Pavel Jelinek 2014-05-26 05:23:38 EDT
It seems to be caused by hanging org.jboss.as.test.integration.osgi.management.FrameworkManagementTestCase.
Comment 5 Pavel Jelinek 2014-07-25 06:41:37 EDT

*** This bug has been marked as a duplicate of bug 1021486 ***

Note You need to log in before you can comment on or make changes to this bug.