Bug 1021504 - RepoError when installing with no network
RepoError when installing with no network
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 08:25 EDT by Michael Simacek
Modified: 2013-11-04 09:44 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-04 09:44:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-tb (661.01 KB, text/plain)
2013-10-21 08:25 EDT, Michael Simacek
no flags Details

  None (edit)
Description Michael Simacek 2013-10-21 08:25:47 EDT
Created attachment 814559 [details]
anaconda-tb

Description of problem:
anaconda crashes with Error.RepoError in _getMetaLink() in yumRepo.py when no network is available.

Steps to Reproduce:
1. Boot instalation image with no networking enabled
2. Select Installation source and just click done.
3. Select Software selection, tick Administration tools and click done
4. Select Software selection again and it crashes

Additional info:
When run with network connected, the same steps produce just dependency resolution error "libquvi-scripts... requires lua-expat", but it doesn't crash
Comment 1 Michael Simacek 2013-11-04 04:33:21 EST
Cannot reproduce in Fedora 20 Beta RC2.
Seems to be fixed.
Comment 2 David Shea 2013-11-04 09:44:07 EST
Closing per comment 1

Note You need to log in before you can comment on or make changes to this bug.