Bug 1021512 - cups-browsed opens many connection an don't close it
cups-browsed opens many connection an don't close it
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cups-filters (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 08:41 EDT by Jürgen Holm
Modified: 2013-11-10 01:38 EST (History)
3 users (show)

See Also:
Fixed In Version: cups-filters-1.0.40-4.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 01:38:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cups-browsed.conf (1.14 KB, text/plain)
2013-10-21 09:38 EDT, Jürgen Holm
no flags Details

  None (edit)
Description Jürgen Holm 2013-10-21 08:41:39 EDT
Description of problem:
With cups-filters-1.0.40-3.fc19.x86_64 I got many (currently ~300 ) CLOSE_WAIT connections
tcp        1      0 Enterprise.theori:58593 cups.theorie.physik:ipp CLOSE_WAIT  1010/cups-browsed   

and ~6 ESTABLISHED connections:
tcp        0      0 Enterprise.theori:33139 cups.theorie.physik:ipp ESTABLISHED 1010/cups-browsed  

Because of this our cups server, responseable for ~100 clients breaks with MaxClients too low: Max clients reached, holding new connections...

Version-Release number of selected component (if applicable):
1.0.40-3.fc19.x86_64

How reproducible:
always

Steps to Reproduce:
1. systemctl start  cups-browsed.service
2. wait a couple of hours and see netstat -tap|grep cups-browsed
3.

Actual results:


Expected results:


Additional info:
No problems with 1.0.34-7.fc19.x86_64

Temporary fix:
cat <<EOF >/etc/cron.hourly/restart-cups-browsed
#!/bin/bash
systemctl start  cups-browsed.service
EOF
chmod a+x /etc/cron.hourly/restart-cups-browsed
Comment 1 Tim Waugh 2013-10-21 09:00:14 EDT
Please attach /etc/cups/cups-browsed.conf.

It looks like the IPP subscriptions code has a socket leak somewhere. :-(
Comment 3 Jürgen Holm 2013-10-21 09:38:21 EDT
Created attachment 814606 [details]
cups-browsed.conf

The host to poll cups resolves:
Enterprise: ~>host cups
cups.theorie.physik.uni-goettingen.de has address 134.76.88.193
Comment 4 Tim Waugh 2013-10-21 09:41:35 EDT
Thanks.

I think I've found the leaks.
Comment 5 Fedora Update System 2013-10-21 09:43:03 EDT
cups-filters-1.0.40-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/cups-filters-1.0.40-4.fc19
Comment 6 Fedora Update System 2013-10-22 01:02:23 EDT
Package cups-filters-1.0.40-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cups-filters-1.0.40-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19662/cups-filters-1.0.40-4.fc19
then log in and leave karma (feedback).
Comment 7 Jürgen Holm 2013-10-22 04:44:20 EDT
Ok, 1.0.40-4 fix the Bug.
Thanks for the hispeed fix!
Comment 8 Tim Waugh 2013-10-22 07:44:46 EDT
Thanks. Sent upstream.
Comment 9 Fedora Update System 2013-10-23 03:10:20 EDT
cups-filters-1.0.40-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-18453/cups-filters-1.0.40-4.fc20
Comment 10 Fedora Update System 2013-10-29 21:58:31 EDT
cups-filters-1.0.40-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Tim Waugh 2013-11-04 09:40:48 EST
Re-opening for Fedora 20.
Comment 12 Fedora Update System 2013-11-10 01:38:53 EST
cups-filters-1.0.40-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.