Bug 1021536 - Setting Qpid SSL protocol sets wrong variable
Setting Qpid SSL protocol sets wrong variable
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
3.0
Unspecified Unspecified
high Severity high
: rc
: 4.0
Assigned To: Eric Harney
Haim
: TestOnly
Depends On: 996766 1021537
Blocks: 1055616
  Show dependency treegraph
 
Reported: 2013-10-21 09:20 EDT by Xavier Queralt
Modified: 2016-04-26 14:26 EDT (History)
15 users (show)

See Also:
Fixed In Version: openstack-cinder-2013.2-5.el6ost
Doc Type: Bug Fix
Doc Text:
By default, QPID uses TCP as a connection transport instead of connection protocol. Previously, the procedure for enabling SSL in QPID connections was to set 'qpid_protocol = ssl' in /etc/glance/glance-api.conf. This setting, however, sets connection protocol; the python-qpid client, on the other hand, expects a connection transport type. The mismatch prevented QPID from actually establishing an SSL connection. With this release, the 'qpid_protocol = ssl' setting now enables SSL for the connection transport instead of connection protocol. As such, QPID can now successfully establish SSL connections.
Story Points: ---
Clone Of: 996766
: 1045057 (view as bug list)
Environment:
Last Closed: 2013-12-19 19:30:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1158807 None None None Never
OpenStack gerrit 47574 None None None Never
OpenStack gerrit 56993 None None None Never

  None (edit)
Comment 3 Eric Harney 2013-12-04 15:27:00 EST
This is fixed in Cinder 2013.2 / RHOS 4.

- a7d47c4 Update to latest copy of OSLO incubator
Comment 4 Eric Harney 2013-12-04 15:28:12 EST
Will leave in POST since not ACK'd.
Comment 15 errata-xmlrpc 2013-12-19 19:30:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.