Bug 1021542 - Got “ImportError: No module named dbus_bindings” with available list .
Got “ImportError: No module named dbus_bindings” with available list .
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Carter Kozak
John Sefler
:
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2013-10-21 09:28 EDT by spandey
Modified: 2015-04-23 19:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-31 05:03:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description spandey 2013-10-21 09:28:23 EDT
Description of problem:


Version-Release number of selected component (if applicable):


Prerequisites:
Rhel 7 with following subscription-manager rpm 
 subscription-manager-migration-data-2.0.5-1.git.0.3be2ad4.el7.noarch
subscription-manager-gui-1.10.4-1.git.0.e94d2a9.el7.x86_64
subscription-manager-firstboot-1.10.4-1.git.0.e94d2a9.el7.x86_64
subscription-manager-migration-1.10.4-1.git.0.e94d2a9.el7.x86_64
subscription-manager-1.10.4-1.git.0.e94d2a9.el7.x86_64


Steps to repro : 
Register client to candlepin and list available subscription using gui or cli . 

Expected Result : 
available subscription should display on screen 

Actual Result : 
Getting time out error with ImportError: No module named dbus_bindings

2013-10-22 04:25:05,218 [DEBUG] subscription-manager-gui @managerlib.py:481 - Refreshing pools from server...
2013-10-22 04:25:05,219 [INFO] subscription-manager-gui @cache.py:168 - Checking current system info against cache: /var/lib/rhsm/facts/facts.json
2013-10-22 04:25:05,219 [INFO] subscription-manager-gui @cache.py:185 - No changes.
2013-10-22 04:25:05,219 [INFO] subscription-manager-gui @cache.py:346 - Server does not support packages, skipping profile upload.
2013-10-22 04:25:05,220 [DEBUG] subscription-manager-gui @connection.py:420 - Loading CA PEM certificates from: /etc/rhsm/ca/
2013-10-22 04:25:05,221 [DEBUG] subscription-manager-gui @connection.py:402 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
2013-10-22 04:25:05,221 [DEBUG] subscription-manager-gui @connection.py:402 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
2013-10-22 04:25:05,223 [DEBUG] subscription-manager-gui @connection.py:402 - Loading CA certificate: '/etc/rhsm/ca/candlepin-ca.pem'
2013-10-22 04:25:05,223 [DEBUG] subscription-manager-gui @connection.py:402 - Loading CA certificate: '/etc/rhsm/ca/10.pem'
2013-10-22 04:25:05,224 [DEBUG] subscription-manager-gui @connection.py:441 - Making request: GET /candlepin/consumers/ea19b3a0-303e-4539-8121-d0164db61141/owner
2013-10-22 04:25:05,283 [DEBUG] subscription-manager-gui @connection.py:460 - Response status: 200
2013-10-22 04:25:05,283 [WARNING] subscription-manager-gui @connection.py:464 - Clock skew detected, please check your system time
2013-10-22 04:25:05,284 [DEBUG] subscription-manager-gui @connection.py:420 - Loading CA PEM certificates from: /etc/rhsm/ca/
2013-10-22 04:25:05,285 [DEBUG] subscription-manager-gui @connection.py:402 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
2013-10-22 04:25:05,285 [DEBUG] subscription-manager-gui @connection.py:402 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
2013-10-22 04:25:05,285 [DEBUG] subscription-manager-gui @connection.py:402 - Loading CA certificate: '/etc/rhsm/ca/candlepin-ca.pem'
2013-10-22 04:25:05,286 [DEBUG] subscription-manager-gui @connection.py:402 - Loading CA certificate: '/etc/rhsm/ca/10.pem'
2013-10-22 04:25:05,286 [DEBUG] subscription-manager-gui @connection.py:441 - Making request: GET /candlepin/owners/admin/pools?consumer=ea19b3a0-303e-4539-8121-d0164db61141
2013-10-22 04:26:05,357 [ERROR] subscription-manager-gui @utils.py:75 - timed out
Traceback (most recent call last):
  File "/usr/sbin/subscription-manager-gui", line 77, in <module>
    import dbus.dbus_bindings
ImportError: No module named dbus_bindings
Comment 2 Carter Kozak 2013-10-21 11:18:22 EDT
I cannot reproduce this.  Can you provide more information about which rhel build you're using.  Is it a minimal install?  Are you using at-spi accessibility?
Comment 3 spandey 2013-10-22 02:42:55 EDT
rhel build 
Red Hat Enterprise Linux Server release 7.0 Beta (Maipo)


 import dbus.dbus_bindings got with Gui list available 

following error got with cli available list 

2013-10-22 23:08:10,596 [DEBUG] subscription-manager @connection.py:441 - Making request: GET /candlepin/owners/admin/pools?consumer=949752e9-1607-4494-8db1-3136060a0f7a
2013-10-22 23:09:10,663 [ERROR] subscription-manager @managercli.py:153 - exception caught in subscription-manager
2013-10-22 23:09:10,663 [ERROR] subscription-manager @managercli.py:154 - timed out
Traceback (most recent call last):
  File "/usr/sbin/subscription-manager", line 82, in <module>
    sys.exit(abs(main() or 0))
  File "/usr/sbin/subscription-manager", line 73, in main
    return managercli.ManagerCLI().main()
  File "/usr/share/rhsm/subscription_manager/managercli.py", line 2279, in main
    return CLI.main(self)
  File "/usr/share/rhsm/subscription_manager/cli.py", line 166, in main
    return cmd.main()
  File "/usr/share/rhsm/subscription_manager/managercli.py", line 443, in main
    return_code = self._do_command()
  File "/usr/share/rhsm/subscription_manager/managercli.py", line 2075, in _do_command
    uninstalled=self.options.match_installed)
  File "/usr/share/rhsm/subscription_manager/managerlib.py", line 320, in get_available_entitlements
    overlapping, uninstalled, text)
  File "/usr/share/rhsm/subscription_manager/managerlib.py", line 518, in get_filtered_pools_list
    self.identity.uuid, self.facts, active_on=active_on):
  File "/usr/share/rhsm/subscription_manager/managerlib.py", line 297, in list_pools
    active_on=active_on, owner=ownerid)
  File "/usr/lib64/python2.7/site-packages/rhsm/connection.py", line 971, in getPoolsList
    results = self.conn.request_get(method)
  File "/usr/lib64/python2.7/site-packages/rhsm/connection.py", line 541, in request_get
    return self._request("GET", method)
  File "/usr/lib64/python2.7/site-packages/rhsm/connection.py", line 455, in _request
    response = conn.getresponse()
  File "/usr/lib64/python2.7/httplib.py", line 1045, in getresponse
    response.begin()
  File "/usr/lib64/python2.7/httplib.py", line 409, in begin
    version, status, reason = self._read_status()
  File "/usr/lib64/python2.7/httplib.py", line 365, in _read_status
    line = self.fp.readline(_MAXLINE + 1)
  File "/usr/lib64/python2.7/socket.py", line 476, in readline
    data = self._sock.recv(self._rbufsize)
  File "/usr/lib64/python2.7/site-packages/M2Crypto/SSL/Connection.py", line 228, in read
    return self._read_bio(size)
  File "/usr/lib64/python2.7/site-packages/M2Crypto/SSL/Connection.py", line 213, in _read_bio
    return m2.ssl_read(self.ssl, size, self._timeout)
SSLTimeoutError: timed out
Comment 4 Carter Kozak 2013-10-30 09:28:16 EDT
For the ssl error in the CLI, we should just print:

>Network error, unable to connect to server.
>Please see /var/log/rhsm/rhsm.log for more information.

Is that not what happens?
Comment 6 spandey 2013-10-31 05:03:38 EDT
issue was i can register machine but i was getting error with available list . 
i was getting import db error and ssl error with available list . 

with updated machine i am not able to reproduce this error , so closing defect ,

Note You need to log in before you can comment on or make changes to this bug.