This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1021548 - opening session menu breaks panel autohide function
opening session menu breaks panel autohide function
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xfce4-panel (Show other bugs)
19
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 09:37 EDT by benvdh
Modified: 2013-11-10 02:08 EST (History)
3 users (show)

See Also:
Fixed In Version: xfce4-panel-4.10.1-3.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-30 23:05:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 714066 None None None Never
Xfce 8960 None None None Never

  None (edit)
Description benvdh 2013-10-21 09:37:37 EDT
Description of problem: When the panel's autohide feature is enabled, and a user opens the session menu, the autohide function stops working. xfce4-panel -r is then needed to enable autohiding again. 


Version-Release number of selected component (if applicable): 4.10.1 (Release: 1.fc19)


When reproducible: Always


Steps to Reproduce:
1.Enable autohiding on the panel. 
2.Open the session menu. 
3.Click the desktop.

Actual results: The panel does not autohide anymore. Only xfce4-panel -r temporarily works around the problem.


Expected results: The panel hides automatically and no longer requires xfce-panel -r to work around the problem.


Additional info:
This bug has already been reported and fixed upstream[1]. However, the patch has not yet been included in an official xfce release[2], nor in fedora 19 (32 bit). See:

[1] https://bugzilla.xfce.org/show_bug.cgi?id=8960
[2] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=714066
Comment 1 Kevin Fenzi 2013-10-21 17:36:48 EDT
Can you test this scratch build and see if the issue is fixed in it: 

http://koji.fedoraproject.org/koji/taskinfo?taskID=6085196
Comment 2 benvdh 2013-10-22 02:30:44 EDT
Hi Kevin,

I just tested the scratch build and it worked. Both after opening the session menu and clicking the desktop and after recovery from a suspended session, the panel kept autohiding. So it works for me! Thanks!

Kind regards,

Ben
Comment 3 Fedora Update System 2013-10-22 14:35:54 EDT
xfce4-panel-4.10.1-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/xfce4-panel-4.10.1-3.fc20
Comment 4 Fedora Update System 2013-10-22 14:37:11 EDT
xfce4-panel-4.10.1-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xfce4-panel-4.10.1-3.fc19
Comment 5 Fedora Update System 2013-10-22 23:29:11 EDT
Package xfce4-panel-4.10.1-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xfce4-panel-4.10.1-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19724/xfce4-panel-4.10.1-3.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-10-30 23:05:00 EDT
xfce4-panel-4.10.1-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2013-11-10 02:08:22 EST
xfce4-panel-4.10.1-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.