Bug 1021556 - [REPORTS-SETUP] - Missing instructions for reports - DB creation in remote DB configuration
[REPORTS-SETUP] - Missing instructions for reports - DB creation in remote DB...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity high
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
Barak Dagan
integration
: Triaged
Depends On: 1039946
Blocks: 3.3snap2 3.3snap4
  Show dependency treegraph
 
Reported: 2013-10-21 09:56 EDT by Barak Dagan
Modified: 2014-01-21 09:55 EST (History)
11 users (show)

See Also:
Fixed In Version: IS26 - rhevm-reports-3.3.0-24.el6ev.noarch.rpm
Doc Type: Bug Fix
Doc Text:
Instructions for creating a remote database did not appear during a user session, which could cause difficulty for users installing reports with a remote database server. Now, the database creation instructions are shown during the interactive setup session.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 09:55:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ovirt-engine-reports-setup log (10.87 KB, text/plain)
2013-11-27 08:09 EST, Barak Dagan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20586 None None None Never
oVirt gerrit 21819 None None None Never

  None (edit)
Description Barak Dagan 2013-10-21 09:56:00 EDT
Description of problem:

while rhevm-setup and rhevm-dwh-setup instructs the admin to performs actions on remote DB machine, the rhevm-reports lack it:

examples:
1) rhevm - setup:
          ATTENTION
         
          Manual action required.
          Please create database for ovirt-engine use. Use the following commands as an example:
         
          create user engine password 'engine';
          create database engine owner engine template template0
          encoding 'UTF8' lc_collate 'en_US.UTF-8'
          lc_ctype 'en_US.UTF-8';
         
          Make sure that database can be accessed remotely.

2) rhevm-dwh-setup
   Remote installation is selected.

Remote installation selected. Make sure that DBA creates a user and the database in the following fashion:
	create role <role> with login encrypted password <password>;
	create ovirt_engine_history owner <role>;


3) rhevm-reports-setup

Welcome to ovirt-engine-reports setup utility
In order to proceed the installer must stop the ovirt-engine service
Would you like to stop the ovirt-engine service (yes|no): yes
Stopping ovirt-engine...                              [ DONE ]
Remote database found.
Setup could not connect to remote database server with automatically detected credentials. Would you like to manually provide db credentials? (yes|no):

Version-Release number of selected component (if applicable):
is19

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
to have instruction which DB and users should be created for the reports DB

Additional info:
Comment 1 Barak 2013-10-22 04:57:59 EDT
Yaniv, Barak,

Why is this an issue ?
All the credentials and configuration are created by the DWH setup, and we know it was checked on the dwh-setup.
In addition even if we do support (down the road) installing reports on a separate server (from engine & dwh), we still should provide the same credentials and access details as dwh.

One different thing that pops to mind is about the access to the db check, shouldn't we do it prior to the engine stop ?
Comment 2 Yaniv Lavi 2013-10-22 05:01:37 EDT
(In reply to Barak from comment #1)
> Yaniv, Barak,
> 
> Why is this an issue ?
> All the credentials and configuration are created by the DWH setup, and we
> know it was checked on the dwh-setup.
> In addition even if we do support (down the road) installing reports on a
> separate server (from engine & dwh), we still should provide the same
> credentials and access details as dwh.
> 
> One different thing that pops to mind is about the access to the db check,
> shouldn't we do it prior to the engine stop ?

This is an text issue that is missing for reports setup and exists in engine and dwh telling the user how to configure a remote db for setup to use.



Yaniv
Comment 3 Barak Dagan 2013-10-22 07:16:38 EDT
(In reply to Barak from comment #1)
> Yaniv, Barak,
> 
> Why is this an issue ?
> All the credentials and configuration are created by the DWH setup, and we
> know it was checked on the dwh-setup.
> In addition even if we do support (down the road) installing reports on a
> separate server (from engine & dwh), we still should provide the same
> credentials and access details as dwh.
> 
> One different thing that pops to mind is about the access to the db check,
> shouldn't we do it prior to the engine stop ?

I agree with your comment, should I open new BZs for it ?
Comment 4 Barak 2013-10-24 13:28:22 EDT
(In reply to Yaniv Dary from comment #2)
> (In reply to Barak from comment #1)
> > Yaniv, Barak,
> > 
> 
> This is an text issue that is missing for reports setup and exists in engine
> and dwh telling the user how to configure a remote db for setup to use.
> 

The point is that when you install reports , these instructions should not be relevant, the user should have used those instruction prior to the DWH installation
Comment 5 Yaniv Lavi 2013-10-26 19:52:39 EDT
(In reply to Barak from comment #4)
> (In reply to Yaniv Dary from comment #2)
> > (In reply to Barak from comment #1)
> > > Yaniv, Barak,
> > > 
> > 
> > This is an text issue that is missing for reports setup and exists in engine
> > and dwh telling the user how to configure a remote db for setup to use.
> > 
> 
> The point is that when you install reports , these instructions should not
> be relevant, the user should have used those instruction prior to the DWH
> installation

But it's not the same user or db name.
Comment 6 Alex Lourie 2013-10-27 09:36:35 EDT
(In reply to Barak from comment #4)
> (In reply to Yaniv Dary from comment #2)
> > (In reply to Barak from comment #1)
> > > Yaniv, Barak,
> > > 
> > 
> > This is an text issue that is missing for reports setup and exists in engine
> > and dwh telling the user how to configure a remote db for setup to use.
> > 
> 
> The point is that when you install reports , these instructions should not
> be relevant, the user should have used those instruction prior to the DWH
> installation

@Barak

We now use a separate user for the each of engine, history and reports installation.

Patch is uploaded for review.
Comment 8 Barak Dagan 2013-11-27 07:55:00 EST
verification failed IS24.2, 
jasperreports-server-pro-5.5.0-4.el6ev.noarch
rhevm-dwh-3.3.0-23.el6ev.noarch
rhevm-reports-3.3.0-22.el6ev.noarch

# rhevm-reports-setup 
Welcome to ovirt-engine-reports setup utility
In order to proceed the installer must stop the ovirt-engine service
Would you like to stop the ovirt-engine service (yes|no): yes
Stopping ovirt-engine...                              [ DONE ]
Remote database found.
Setup could not connect to remote database server with automatically detected credentials. Would you like to manually provide db credentials? (yes|no): no
Error: cannot connect to the remote db with the provided credentials. User decided to exit.
Error encountered while installing ovirt-engine-reports, please consult the log file: /var/log/ovirt-engine/ovirt-engine-reports-setup-2013_11_26_13_06_01.log
[root@fire33-remrep yum.repos.d]# less /var/log/ovirt-engine/ovirt-engine-reports-setup-2013_11_26_13_06_01.log
Comment 9 Barak Dagan 2013-11-27 08:09:04 EST
Created attachment 829715 [details]
ovirt-engine-reports-setup log
Comment 10 Charlie 2013-11-27 19:49:09 EST
This bug is currently attached to errata RHEA-2013:15115. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 11 Alex Lourie 2013-11-28 05:39:33 EST
@ Chris

I've added doc note.

@ Barak

It's a regressions. I've created a fix, now in review. To verify you would need to say [yes] first to the question "Would you like to manually provide db credentials?", then you'll see the instructions.
Comment 13 Barak Dagan 2014-01-16 19:15:30 EST
verified is32.2:

rhevm-reports-3.3.0-28.el6ev.noarch
rhevm-dwh-3.3.0-28.el6ev.noarch
jasperreports-server-pro-5.5.0-4.el6ev.noarch

the following message logged in the consil during atteneded installation:

Stopping ovirt-engine...                              [ DONE ]
Backing up reports DB...                              [ DONE ]
Remote database not found.
Remote installation selected. Make sure that DBA creates a user and the database in the following fashion:
	create role <role> with login encrypted password '<password>';
	create database rhevmreports template template0 encoding 'UTF8' lc_collate 'en_US.UTF-8' lc_ctype 'en_US.UTF-8' owner <role>;
Comment 15 errata-xmlrpc 2014-01-21 09:55:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0035.html

Note You need to log in before you can comment on or make changes to this bug.