Bug 1021558 - Spacewalk fails to generate DEB repository error on "setBuildTime"
Spacewalk fails to generate DEB repository error on "setBuildTime"
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Mráka
Red Hat Satellite QA List
:
Depends On:
Blocks: space22
  Show dependency treegraph
 
Reported: 2013-10-21 10:00 EDT by Martin Juhl
Modified: 2014-07-17 04:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: spacewalk-java-2.2.12-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-17 04:40:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhn_taskomatic_daemon.log (163.85 KB, text/x-log)
2013-10-21 10:00 EDT, Martin Juhl
no flags Details
Solves problem, but maybe not the right way?? (1.55 KB, patch)
2013-12-02 09:31 EST, Martin Juhl
no flags Details | Diff

  None (edit)
Description Martin Juhl 2013-10-21 10:00:11 EDT
Created attachment 814615 [details]
rhn_taskomatic_daemon.log

Description of problem:

After pushing a debian package:
http://nl.archive.ubuntu.com/ubuntu/pool/universe/j/joe/joe_3.7-2.3_amd64.deb

Spacewalk fails to generate repository metadata and fails with error: 

com.redhat.rhn.frontend.dto.PackageDto.setBuildTime(PackageDto.java:279)

I have tried with several different packages, all with the same result..

I have seen this working in the previous version (1.9)...

How reproducible:
Everytime

Steps to Reproduce:
1. Create channel, debian based (IA32 Debian or AMD64 Debian)
2. Push package to created channel..

Actual results:
Error appears in /var/log/rhn/rhn_taskomatic_daemon.log

Expected results:
Channel Metadate should be created...

Additional info:
/var/log/rhn/rhn_taskomatic_daemon.log is attached...
Comment 1 Martin Juhl 2013-12-02 09:31:19 EST
Created attachment 831605 [details]
Solves problem, but maybe not the right way??

I have discovered that the reason for the failure is that the setBuildTime() function is called with an argument "buildTimeIn=NULL".. 

The attached patch handles this exception, even though I'm not sure that's the right way to fix the problem..
Comment 2 Martin Juhl 2014-01-27 07:31:35 EST
Any comments on this patch???

Is it something we can get implemented???
Comment 3 Dirk Götz 2014-02-21 10:12:04 EST
I am running in the same problem. 

I have created a rhn.jar with the patch applied and it works, but there is no date for last repo build and no information on repo cache status shown.

Perhaps this is the result from building the jar by unpacking, compiling the class file and repacking. But I have not got a good setup working.
Comment 4 Michael Mráka 2014-03-07 08:05:48 EST
Fixed in spacewalk master by
commit 47e451d0c39986766b63e29e56236df27aeb4b41
    1021558 - if buildTime is null don't parse it
Comment 5 Milan Zazrivec 2014-07-17 04:40:45 EDT
Spacewalk 2.2 has been released:

    https://fedorahosted.org/spacewalk/wiki/ReleaseNotes22

Note You need to log in before you can comment on or make changes to this bug.