Bug 1021563 - Node sync throwing trace in child pulp logs re: missing resource
Node sync throwing trace in child pulp logs re: missing resource
Status: CLOSED UPSTREAM
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
:
: 1145710 1192031 (view as bug list)
Depends On: 1145710
Blocks: 1338516 sat6-pulp-future
  Show dependency treegraph
 
Reported: 2013-10-21 10:11 EDT by Corey Welton
Modified: 2017-07-26 15:40 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1145710 (view as bug list)
Environment:
Last Closed: 2016-02-15 13:36:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Pulp Redmine 537 Normal CLOSED - CURRENTRELEASE Node sync throwing trace in child pulp logs re: missing resource Never

  None (edit)
Description Corey Welton 2013-10-21 10:11:53 EDT
Description of problem:
I'm getting a weird trace in pulp logs about resources not being found for sync -- even though the content is there.  At very least we should handle cleanly a missing resource, though we should also probably try and figure out why it can't find the content

Version-Release number of selected component (if applicable):

Satellite-6.0.2-RHEL-6-20131016.0


How reproducible:
Every time so far - though it's hard to nail down any exact repro path out of the ordinary.  Seems like a vanilla usepath.

Steps to Reproduce:
1.  Create a content view with RHEL content and publish
2.  Attempt to sync to child node
3.  View the pulp logs on child node.

Actual results:


2013-10-21 09:59:58,503 pulp.server.webservices.middleware.exception:ERROR: Missing resource(s): repo=Katello_Infrastructure-Library-PublishedRHEL6Composite64-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_6_Server_RPMs_x86_64_6Server
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/middleware/exception.py", line 44, in __call__
    return self.app(environ, start_response)
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/middleware/postponed.py", line 39, in __call__
    return self.app(environ, start_response)
  File "/usr/lib/python2.6/site-packages/web/application.py", line 278, in wsgi
    result = self.handle_with_processors()
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in _handle_with_processors
    return process(self.processors)
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 23, in process
    return p(lambda : process(processors))
  File "/usr/lib/python2.6/site-packages/web/application.py", line 557, in processor
    return handler()
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 23, in <lambda>
    return p(lambda : process(processors))
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 23, in process
    return p(lambda : process(processors))
  File "/usr/lib/python2.6/site-packages/web/application.py", line 572, in processor
    result = handler()
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 23, in <lambda>
    return p(lambda : process(processors))
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 25, in process
    return self.handle()
  File "/usr/lib/python2.6/site-packages/web/application.py", line 232, in handle
    return self._delegate(fn, self.fvars, args)
  File "/usr/lib/python2.6/site-packages/web/application.py", line 413, in _delegate
    return f()
  File "/usr/lib/python2.6/site-packages/web/application.py", line 421, in <lambda>
    f = lambda: self._delegate_sub_application(pat, what)
  File "/usr/lib/python2.6/site-packages/web/application.py", line 446, in _delegate_sub_application
    return app.handle_with_processors()
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in _handle_with_processors
    return process(self.processors)
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 23, in process
    return p(lambda : process(processors))
  File "/usr/lib/python2.6/site-packages/web/application.py", line 557, in processor
    return handler()
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 23, in <lambda>
    return p(lambda : process(processors))
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 23, in process
    return p(lambda : process(processors))
  File "/usr/lib/python2.6/site-packages/web/application.py", line 572, in processor
    result = handler()
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 23, in <lambda>
    return p(lambda : process(processors))
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 25, in process
    return self.handle()
  File "/usr/lib/python2.6/site-packages/web/application.py", line 232, in handle
    return self._delegate(fn, self.fvars, args)
  File "/usr/lib/python2.6/site-packages/web/application.py", line 411, in _delegate
    return handle_class(cls)
  File "/usr/lib/python2.6/site-packages/web/application.py", line 386, in handle_class
    return tocall(*args)
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/controllers/decorators.py", line 227, in _auth_decorator
    value = method(self, *args, **kwargs)
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/controllers/repositories.py", line 245, in GET
    raise exceptions.MissingResource(repo=id)
MissingResource: Missing resource(s): repo=Katello_Infrastructure-Library-PublishedRHEL6Composite64-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_6_Server_RPMs_x86_64_6Server
2013-10-21 09:59:58,674 pulp.server.dispatch.task:INFO: SUCCESS: Task e4afe72b-8306-4086-9f6f-b47c2ce59e25: CallRequest: RepoManager.create_and_configure_repo('Katello_Infrastructure-Library-PublishedRHEL6Composite64-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_6_Server_RPMs_x86_64_6Server', 'Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server', None, {'_repo-type': 'rpm-repo'}, importer_repo_plugin_config=****, distributor_list=****, importer_type_id=None)



Expected results:

Not sure why it can't find content, but even if it were true that the content wasn't actually there, we should handle the error condition in a friendly way.

Additional info:
Comment 2 Mike McCune 2013-10-22 00:07:33 EDT
Justin, if this is non-fatal and just extra log spam we can move this onto MDP3+ but if it actually effects the success story lets fix it.
Comment 3 Justin Sherrill 2013-10-22 09:23:55 EDT
Mike, As far as I can tell this is non-fatal, the repositories get published (as long as they have no distributions due to other bz).  It would be good to have jortel look at this to ensure there isnt' something behind the scenes happening that we can't tell.
Comment 4 Og Maciel 2013-10-24 12:25:24 EDT
Saw it happen twice already, apparently affecting the kickstart repos:

MissingResource: Missing resource(s): repo=Katello_Infrastructure-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_6_Server_Kickstart_i386_6Server

and 

MissingResource: Missing resource(s): repo=Katello_Infrastructure-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_5_Server_Kickstart_i386_5Server
Comment 7 Brad Buckingham 2015-02-13 11:11:10 EST
*** Bug 1192031 has been marked as a duplicate of this bug. ***
Comment 9 Brian Bouterse 2015-03-05 16:50:19 EST
*** Bug 1145710 has been marked as a duplicate of this bug. ***
Comment 10 pulp-infra@redhat.com 2015-04-23 12:40:20 EDT
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.
Comment 11 Bryan Kearney 2016-02-15 13:36:10 EST
Fixed in upstream, and a very old bug. I am marking this as CLOSED/UPSTREAM. Please re-open if you are still seeing this issue.

Note You need to log in before you can comment on or make changes to this bug.