Bug 1021568 - Pulp unable to find content on parent that is quite evidently there.
Pulp unable to find content on parent that is quite evidently there.
Status: CLOSED DUPLICATE of bug 1020549
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 10:25 EDT by Corey Welton
Modified: 2014-01-27 09:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-21 11:34:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2013-10-21 10:25:11 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Attempt to sync content from parent
2.  follow pulp log on child
3.  Noting reference to missing files (see results below), attempt to find these files on parent.

Actual results:
2013-10-21 10:03:49,767 pulp.plugins.yum_distributor.distributor:INFO: Publish complete:  summary = <{'num_package_units_errors': 0, 'https_publish_dir': u'/var/lib/pulp/published/https/repos/Katello_Infrastructure/Library/PublishedRHEL6CVD64/content/dist/rhel/server/6/6Server/x86_64/os', 'num_package_categories_published': 0, 'num_distribution_units_errors': 7, 'skip_metadata_update': False, 'num_distribution_units_published': -6, 'num_package_groups_published': 202, 'num_package_units_attempted': 6686, 'num_package_units_published': 6686, 'num_distribution_units_attempted': 1, 'relative_path': u'Katello_Infrastructure/Library/PublishedRHEL6CVD64/content/dist/rhel/server/6/6Server/x86_64/os'}>, details = <{'errors': [(u'/var/lib/pulp/content/distribution/ks-Red Hat Enterprise Linux-Server-6.4-x86_64/images/efiboot.img', u'/var/lib/pulp/working/repos/Katello_Infrastructure-Library-PublishedRHEL6CVD64-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_6_Server_RPMs_x86_64_6Server/distributors/yum_distributor/images/efiboot.img', u'Source path: /var/lib/pulp/content/distribution/ks-Red Hat Enterprise Linux-Server-6.4-x86_64/images/efiboot.img is missing'), (u'/var/lib/pulp/content/distribution/ks-Red Hat Enterprise Linux-Server-6.4-x86_64/images/pxeboot/vmlinuz', u'/var/lib/pulp/working/repos/Katello_Infrastructure-Library-PublishedRHEL6CVD64-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_6_Server_RPMs_x86_64_6Server/distributors/yum_distributor/images/pxeboot/vmlinuz', u'Source path: /var/lib/pulp/content/distribution/ks-Red Hat Enterprise Linux-Server-6.4-x86_64/images/pxeboot/vmlinuz is missing'), (u'/var/lib/pulp/content/distribution/ks-Red Hat Enterprise Linux-Server-6.4-x86_64/images/product.img', u'/var/lib/pulp/working/repos/Katello_Infrastructure-Library-PublishedRHEL6CVD64-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_6_Server_RPMs_x86_64_6Server/distributors/yum_distributor/images/product.img', u'Source path: /var/lib/pulp/content/distribution/ks-Red Hat Enterprise Linux-Server-6.4-x86_64/images/product.img is missing'), (u'/var/lib/pulp/content/distribution/ks-Red Hat Enterprise Linux-Server-6.4-x86_64/images/pxeboot/initrd.img', u'/var/lib/pulp/working/repos/Katello_Infrastructure-Library-PublishedRHEL6CVD64-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_6_Server_RPMs_x86_64_6Server/distributors/yum_distributor/images/pxeboot/initrd.img', u'Source path: /var/lib/pulp/content/distribution/ks-Red Hat Enterprise Linux-Server-6.4-x86_64/images/pxeboot/initrd.img is missing'), (u'/var/lib/pulp/content/distribution/ks-Red Hat Enterprise Linux-Server-6.4-x86_64/images/efidisk.img', u'/var/lib/pulp/working/repos/Katello_Infrastructure-Library-PublishedRHEL6CVD64-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_6_Server_RPMs_x86_64_6Server/distributors/yum_distributor/images/efidisk.img', u'Source path: /var/lib/pulp/content/distribution/ks-Red Hat Enterprise Linux-Server-6.4-x86_64/images/efidisk.img is missing'), (u'/var/lib/pulp/content/distribution/ks-Red Hat Enterprise Linux-Server-6.4-x86_64/images/install.img', u'/var/lib/pulp/working/repos/Katello_Infrastructure-Library-PublishedRHEL6CVD64-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_6_Server_RPMs_x86_64_6Server/distributors/yum_distributor/images/install.img', u'Source path: /var/lib/pulp/content/distribution/ks-Red Hat Enterprise Linux-Server-6.4-x86_64/images/install.img is missing'), (u'/var/lib/pulp/content/distribution/ks-Red Hat Enterprise Linux-Server-6.4-x86_64/images/boot.iso', u'/var/lib/pulp/working/repos/Katello_Infrastructure-Library-PublishedRHEL6CVD64-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_6_Server_RPMs_x86_64_6Server/distributors/yum_distributor/images/boot.iso', u'Source path: /var/lib/pulp/content/distribution/ks-Red Hat Enterprise Linux-Server-6.4-x86_64/images/boot.iso is missing')], 'time_metadata_sec': 249.39879894256592}>

On parent:

[root@mgmt2 ~]# ls "/var/lib/pulp/content/distribution/ks-Red Hat Enterprise Linux-Server-6.4-x86_64/images/pxeboot/vmlinuz"
/var/lib/pulp/content/distribution/ks-Red Hat Enterprise Linux-Server-6.4-x86_64/images/pxeboot/vmlinuz


Expected results:

Should be able to find content?

Additional info:
Comment 2 Justin Sherrill 2013-10-21 11:34:32 EDT

*** This bug has been marked as a duplicate of bug 1020549 ***

Note You need to log in before you can comment on or make changes to this bug.