Bug 1021611 - upgrade from legacy should allow use of answer file
upgrade from legacy should allow use of answer file
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: 3.4.0
Assigned To: Sandro Bonazzola
sefi litmanovich
integration
: TestOnly, ZStream
Depends On:
Blocks: 1094775
  Show dependency treegraph
 
Reported: 2013-10-21 11:51 EDT by Alon Bar-Lev
Modified: 2014-06-12 10:07 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1094775 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alon Bar-Lev 2013-10-21 11:51:33 EDT
Example of breakage:

 legacy/database.py

We assume that we can ask user if he wants tls and host verify.

So either have legacy specific environment with defaults or other solution.

Should check other sequences as well.
Comment 2 Sandro Bonazzola 2014-05-06 05:47:53 EDT
In 3.4.0 this bug can't be reproduced since upgrade from legacy is not in the setup code anymore.
In order to test this on 3.4, just try to upgrade from 3.3.z using an answer file.
It may probably have been already verified by CI automated tests.
Comment 4 sefi litmanovich 2014-05-07 05:03:37 EDT
Verified according to comment 2 - upgrading rhevm from 3.3.3 to latest 3.4 using an answer file. - upgrade successful.
Comment 5 Itamar Heim 2014-06-12 10:07:45 EDT
Closing as part of 3.4.0

Note You need to log in before you can comment on or make changes to this bug.