Bug 1021661 - Red Hat Storage Management Console rhel-x86_64-server-6-rhs-rhsc-2.1 channel maps are missing
Summary: Red Hat Storage Management Console rhel-x86_64-server-6-rhs-rhsc-2.1 channel ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager-migration-data
Version: 6.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Alex Wood
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2013-10-21 18:16 UTC by John Sefler
Modified: 2018-12-06 15:23 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no documentation required
Clone Of:
Environment:
Last Closed: 2014-10-14 07:45:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1146113 None None None Never
Red Hat Product Errata RHBA-2014:1384 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2014-10-14 01:27:50 UTC

Description John Sefler 2013-10-21 18:16:32 UTC
Description of problem:
Version 2.1 product cert channel mappings for Red Hat Storage Management Console are missing from the subscription-manager-migration-data
 rhel-x86_64-server-6-rhs-rhsc-2.1
 rhel-x86_64-server-6-rhs-rhsc-2.1-debuginfo

Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-2.0.5-1.el6.noarch


How reproducible:


Steps to Reproduce:
[root@jsefler-6 ~]# rpm -ql subscription-manager-migration-data | grep mapping
/usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt

[root@jsefler-6 ~]# grep rhs-rhsc /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-x86_64-server-6-rhs-rhsc-2.0: RHS-Console-x86_64-3c77c5245214-188.pem
rhel-x86_64-server-6-rhs-rhsc-2.0-debuginfo: RHS-Console-x86_64-3c77c5245214-188.pem


Actual results:
above shows product cert mapping for v2.0

Expected results:
also expected v2.1 product cert mapping for channels...
rhel-x86_64-server-6-rhs-rhsc-2.1
rhel-x86_64-server-6-rhs-rhsc-2.1-debuginfo


Additional info:

subscription-manager-migration-data depends on an update to product-certs.json to include these mappings.  Currently these channels are also missing from product-certs.json
http://git.app.eng.bos.redhat.com/rcm/rcm-metadata.git/tree/cdn/product-certs.json?id=HEAD

Comment 1 Dennis Gregorovic 2014-01-08 15:32:22 UTC
Yes, these should be included in the next update.

Comment 2 John Sefler 2014-02-18 14:49:37 UTC
This bug is more applicable to RHEL6 than RHEL7.  Moving back to RHEL6.

Comment 4 Andrew Thomas 2014-07-16 17:22:28 UTC
Updated product-certs contains these mappings

Comment 7 Rehana 2014-07-30 14:07:03 UTC
Retested on rhel6.6 with 

# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-2.0.10-1.el6.noarch

following the test steps mentioned in the bug description

# rpm -ql subscription-manager-migration-data | grep mapping
/usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt


# grep rhs-rhsc /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-x86_64-server-6-rhs-rhsc-2.0: RHS-Console-x86_64-3c77c5245214-188.pem
rhel-x86_64-server-6-rhs-rhsc-2.0-debuginfo: RHS-Console-x86_64-3c77c5245214-188.pem
rhel-x86_64-server-6-rhs-rhsc-2.1: RHS-Console-x86_64-7363b55ffb92-188.pem
rhel-x86_64-server-6-rhs-rhsc-2.1-debuginfo: RHS-Console-x86_64-7363b55ffb92-188.pem


Above mentioned command displays product cert mapping for rhsc version 2.1 along with version 2.0

Additional details:

Also now these mapping details are available in http://git.app.eng.bos.redhat.com/git/rcm/rcm-metadata.git/tree/cdn/product-certs.json?id=HEAD

Marking this bug to "Verified"

Comment 8 errata-xmlrpc 2014-10-14 07:45:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1384.html


Note You need to log in before you can comment on or make changes to this bug.