Bug 1021696 - pear is broken
pear is broken
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Hiro Asari
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 16:07 EDT by Hiro Asari
Modified: 2015-05-14 19:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hiro Asari 2013-10-21 16:07:56 EDT
Description of problem:
As of devenv_3923, 'pear' can write a bad registry file to user installation of a PEAR module, and break the user app.

Version-Release number of selected component (if applicable):
devenv_3923

How reproducible:

Steps to Reproduce:
rhc app create p php-5.3
rhc app ssh p
$ pear install --alldeps Mail
$ pear list Mail

Actual results:
PHP Notice:  unserialize(): Error at offset 7700 of 12711 bytes in /usr/share/pear/PEAR/Registry.php on line 1145
PHP Stack trace:
PHP   1. {main}() /usr/share/pear/pearcmd.php:0
PHP   2. PEAR_Command_Common->run() /usr/share/pear/pearcmd.php:305
PHP   3. PEAR_Command_Registry->doList() /usr/share/pear/PEAR/Command/Common.php:271
PHP   4. PEAR_Command_Registry->doFileList() /usr/share/pear/PEAR/Command/Registry.php:146
PHP   5. PEAR_Registry->getPackage() /usr/share/pear/PEAR/Command/Registry.php:278
PHP   6. PEAR_Registry->_getPackage() /usr/share/pear/PEAR/Registry.php:1962
PHP   7. PEAR_Registry->_packageInfo() /usr/share/pear/PEAR/Registry.php:1443
PHP   8. unserialize() /usr/share/pear/PEAR/Registry.php:1145


Expected results:
[p2-fooooooooooo.dev.rhcloud.com 5265880a6777e3d6ff000005]\> pear list Mail
INSTALLED FILES FOR MAIL
========================
TYPE INSTALL PATH
php  /var/lib/openshift/5265880a6777e3d6ff000005/php/phplib/pear/pear/php/Mail/mail.php
php  /var/lib/openshift/5265880a6777e3d6ff000005/php/phplib/pear/pear/php/Mail/mock.php
php  /var/lib/openshift/5265880a6777e3d6ff000005/php/phplib/pear/pear/php/Mail/null.php
⋮

Additional info:
Comment 1 Hiro Asari 2013-10-21 16:10:09 EDT
*** Bug 1020011 has been marked as a duplicate of this bug. ***
Comment 2 Hiro Asari 2013-10-21 16:25:47 EDT
[root@ip-10-168-47-32 ~]# rpm -qf `which pear`
php-pear-1.9.4-4.el6.noarch

Troy, could you work on a new version of RPM with a newer version of pear?
Comment 3 Hiro Asari 2013-10-21 16:53:07 EDT
This is not necessary.

bin/control in the PHP cart is breaking the registry file.
Comment 4 Hiro Asari 2013-10-21 16:53:07 EDT
This is not necessary.

bin/control in the PHP cart is breaking the registry file.

Note You need to log in before you can comment on or make changes to this bug.