Bug 1021704 - decimal/octal problems with mksh
decimal/octal problems with mksh
Status: CLOSED DUPLICATE of bug 975748
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mksh (Show other bugs)
6.4
Unspecified Linux
unspecified Severity medium
: rc
: ---
Assigned To: Michal Hlavinka
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 16:54 EDT by jbmorris
Modified: 2013-10-29 05:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-22 04:17:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jbmorris 2013-10-21 16:54:34 EDT
Description of problem: Why is the version of mksh 4 years old?  It is R39 and they are up to R48b.  R39 is 4 years old.  The particular issue we've encountered with this is that in certain circumstances it interprets numbers beginning with leading zeroes as octal, which is causing us to have to review and modify quite a lot of code.  Releases of mksh from R46 on make this a global option that can be set.  (set -o posix)  Without this set, they are interpreted as decimal as we expect.


Version-Release number of selected component (if applicable): $ echo $KSH_VERSION
@(#)MIRBSD KSH R39 2009/08/01


How reproducible: if (( 009 == 9 )); then echo equal; fi                                       
mksh:  009 == 9 : bad number '009'


Steps to Reproduce:
1. issue this command: if (( 009 == 9 )); then echo equal; fi                                       
2.
3.

Actual results: You will see this error message:
mksh:  009 == 9 : bad number '009'


Expected results: You should just see the message "equal"


Additional info: We realize we could compile our own version of mksh to work around this, but we prefer to stay with what RedHat supports.  Does RedHat have any intention of supporting newer versions of mksh at some point?
Comment 2 Michal Hlavinka 2013-10-22 04:17:26 EDT
Please beware, that bugzilla is bug tracking tool, nothing more. For support (including questions when/if we update some package) you should open support case at https://access.redhat.com/home

There already is bug for decimal/octal numbers, bug #975748. Closing this one as duplicate.

> Why is the version of mksh 4 years old?

RHEL targets enterprise environments. In such environments unnecessary disruptions should be avoided. This includes different API, behaviour or configuration of any package. What would make one happy, could make tens or hundreds unhappy. That's why we rarely update packages to newer versions, unless there is strong reason (and customer demand). Instead of rebasing packages to newer versions, we backport fixes.

*** This bug has been marked as a duplicate of bug 975748 ***
Comment 3 jbmorris 2013-10-25 14:59:02 EDT
I apologize for duplicating a bug, but I did search for mksh first and this didn't come up.  I just tried to view bug 975748 and it said I wasn't authorized to view it, so I assume that's why it didn't show up in my search.  Just curious why I cannot view that bug.  I'd like to know how long it has been open and when you're planning to backport the fix.
Comment 4 Michal Hlavinka 2013-10-29 05:46:01 EDT
Some bugs are private because they can contain sensitive information.

If you are Red Hat customer, you should use proper support channel (https://access.redhat.com/home) they'd do the search instead of you and inform you about fix availability.

Almost certainly (99.9 %), fix for this bug will be in rhel-6.5 update

Note You need to log in before you can comment on or make changes to this bug.