Bug 1021715 - lvm tools should accept vg uuid as a substitute for name when duplicates are present
lvm tools should accept vg uuid as a substitute for name when duplicates are ...
Status: CLOSED DUPLICATE of bug 449832
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
20
All Linux
unspecified Severity high
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 17:31 EDT by David Lehman
Modified: 2013-10-22 03:03 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-22 03:03:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lehman 2013-10-21 17:31:01 EDT
Description of problem:
During OS installation it is alarmingly common to find multiple VGs with the same name -- often, some of these VGs are also incomplete. Managing this in the context of trying to lay down a sane storage configuration for a new OS installation is impossible when the only way to specify a VG is by name.

Version-Release number of selected component (if applicable):
lvm2-2.02.99

How reproducible:
always

Steps to Reproduce:
1. install system with LVM autopart on system with 2 HDDs
2. install system again with LVM autopart but only with one of those HDD available
3. boot the system with both HDDs present and try to specify which of the two identically-named VGs you want lvm to act on.

Actual results:
problems due to there being no way to differentiate the duplicate VGs when running LVM commands

Expected results:
A way to specify a VG in a way that can reasonably be expected to be unique.

Additional info:
For now, it would suffice to add this ability to lvs, vgchange, and vgremove.
Comment 1 Zdenek Kabelac 2013-10-22 03:03:47 EDT
Yes - we have long term outstanding RFE Bug #449832.

If during the installation process various disks are present to the lvm2 tools - it's probably the best to add some salt to vgname created by installer then,
since no validation could prevent in duplicate name creation.

But anyway specifically in this case the only tool which is designed and does fully work with UUIDs is the vgrename tool  i.e.:

vgrename Zvlifi-Ep3t-e0Ng-U42h-o0ye-KHu1-nl7Ns4 VolGroup00_tmp

*** This bug has been marked as a duplicate of bug 449832 ***

Note You need to log in before you can comment on or make changes to this bug.