Bug 1021718 - Repositories with no URL are not displayed in the UI
Repositories with no URL are not displayed in the UI
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Walden Raines
Katello QA List
: Triaged
Depends On:
Blocks: 1012602
  Show dependency treegraph
 
Reported: 2013-10-21 17:40 EDT by Og Maciel
Modified: 2013-10-24 07:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-24 07:25:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the repo without url does get displayed (211.17 KB, image/png)
2013-10-22 09:30 EDT, Kedar Bidarkar
no flags Details

  None (edit)
Description Og Maciel 2013-10-21 17:40:41 EDT
Description of problem:

Creating a repository with no URL and then browsing all repos for the organization won't display the new repo.

Version-Release number of selected component (if applicable):

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.25-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.25-1.el6sam.noarch
* candlepin-tomcat6-0.8.25-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.3.0-18.el6sat.noarch
* foreman-compute-1.3.0-18.el6sat.noarch
* foreman-libvirt-1.3.0-18.el6sat.noarch
* foreman-postgresql-1.3.0-18.el6sat.noarch
* foreman-proxy-1.3.0-3.el6sat.noarch
* katello-1.4.6-39.el6sat.noarch
* katello-all-1.4.6-39.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.4-1.el6sat.noarch
* katello-cli-1.4.3-24.el6sat.noarch
* katello-cli-common-1.4.3-24.el6sat.noarch
* katello-common-1.4.6-39.el6sat.noarch
* katello-configure-1.4.7-5.el6sat.noarch
* katello-configure-foreman-1.4.7-5.el6sat.noarch
* katello-configure-foreman-proxy-1.4.7-5.el6sat.noarch
* katello-foreman-all-1.4.6-39.el6sat.noarch
* katello-glue-candlepin-1.4.6-39.el6sat.noarch
* katello-glue-elasticsearch-1.4.6-39.el6sat.noarch
* katello-glue-pulp-1.4.6-39.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.4-4.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-katello-plugins-0.2-1.el6sat.noarch
* pulp-nodes-common-2.3.0-0.22.beta.el6sat.noarch
* pulp-nodes-parent-2.3.0-0.22.beta.el6sat.noarch
* pulp-puppet-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-rpm-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-selinux-2.3.0-0.22.beta.el6sat.noarch
* pulp-server-2.3.0-0.22.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.0.7-1.el6sat.noarch
* signo-0.0.22-2.el6sat.noarch
* signo-katello-0.0.22-2.el6sat.noarch

How reproducible:


Steps to Reproduce:
1. Create new org/product/provider
2. Add new yum repo without a url
3. Navigate away from product and back

Actual results:

The repo is not displayed

Expected results:


Additional info:
Comment 1 Kedar Bidarkar 2013-10-22 09:30:30 EDT
Created attachment 815003 [details]
the repo without url does get displayed
Comment 2 Kedar Bidarkar 2013-10-22 09:35:33 EDT
I happened to check this and it looks like it does works with, 
Satellite-6.0.2-RHEL-6-20131021.0
Comment 3 Walden Raines 2013-10-23 17:08:23 EDT
(In reply to Kedar Bidarkar from comment #2)
> I happened to check this and it looks like it does works with, 
> Satellite-6.0.2-RHEL-6-20131021.0

The above steps are not sufficiently specific enough to reproduce this problem.  It seems to happen in some orgs and not in others.  I have seen it myself though so I do know it's happening.
Comment 4 Kedar Bidarkar 2013-10-24 07:22:08 EDT
If I remeber correctly this was an issue with SNAP6, but from compose3, it's no longer an issue. today I checked this even with SNAP7 and Repos without URL do get displayed in the UI. Looks like something did fix it. :)

Note You need to log in before you can comment on or make changes to this bug.