Bug 102172 - redhat-config-users does segmentation fault
redhat-config-users does segmentation fault
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: libuser (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-12 02:21 EDT by Tero Hiekkalinna
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-17 04:22:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tero Hiekkalinna 2003-08-12 02:21:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a)
Gecko/20030728 Mozilla Firebird/0.6.1

Description of problem:
redhat-config-users does segmentation fault in start after I added 40 users from
old system to new system's /etc/passwd, /etc/shadow and /etc/group by "hand"
with vi, vipw and vigr.

% redhat-config-users
/usr/share/redhat-config-users/redhat-config-users: line 4: 12396 Segmentation
fault      /usr/bin/python2.2 /usr/share/redhat-config-users/redhat-config-users.py
%



Version-Release number of selected component (if applicable):
redhat-config-users-1.1.5-7

How reproducible:
Always

Steps to Reproduce:
1. Modify /etc/passwd, /etc/shadow, and /etc/group with vi, vipw and vigr
2. run redhat-config-users


(I guess)    

Actual Results:  I have not re-done it.

Additional info:

I did strace for redhat-config-network (if that helps) and full strace is at:

http://www.cs.helsinki.fi/u/tsjuntun/redhat-config-users-strace.txt

and backtrace is here:

#0  0x40c58d3f in _init () from /usr/lib/libuser/libuser_files.so
#1  0x40c58fea in _init () from /usr/lib/libuser/libuser_files.so
#2  0x40c5e83f in _init () from /usr/lib/libuser/libuser_files.so
#3  0x40c5eab1 in _init () from /usr/lib/libuser/libuser_files.so
#4  0x402db0ce in lu_end () from /usr/lib/libuser.so.1
#5  0x402dc010 in lu_end () from /usr/lib/libuser.so.1
#6  0x402dce17 in lu_end () from /usr/lib/libuser.so.1
#7  0x402def8d in lu_users_enumerate_full () from /usr/lib/libuser.so.1
#8  0x400260ae in _init () from /usr/lib/python2.2/site-packages/libusermodule.so
#9  0x080d0e8e in PyCFunction_Call ()
#10 0x080b3797 in PyObject_Call ()
#11 0x0807c905 in PyEval_GetFuncDesc ()
#12 0x0807a613 in PyEval_EvalCode ()
#13 0x0807b0ce in PyEval_EvalCodeEx ()
#14 0x0807c62b in PyEval_GetFuncDesc ()
#15 0x0807a5a3 in PyEval_EvalCode ()
#16 0x0807b0ce in PyEval_EvalCodeEx ()
#17 0x0807c62b in PyEval_GetFuncDesc ()
#18 0x0807a5a3 in PyEval_EvalCode ()
#19 0x0807b0ce in PyEval_EvalCodeEx ()
#20 0x0807c62b in PyEval_GetFuncDesc ()
#21 0x0807a5a3 in PyEval_EvalCode ()
#22 0x0807b0ce in PyEval_EvalCodeEx ()
#23 0x080c447c in PyFunction_SetClosure ()
#24 0x080b3797 in PyObject_Call ()
#25 0x080ba4ab in PyMethod_New ()
#26 0x080b3797 in PyObject_Call ()
#27 0x0807c2d0 in PyEval_CallObjectWithKeywords ()
#28 0x080b631d in PyInstance_New ()
#29 0x080b3797 in PyObject_Call ()
#30 0x0807c905 in PyEval_GetFuncDesc ()
#31 0x0807a525 in PyEval_EvalCode ()
#32 0x0807b0ce in PyEval_EvalCodeEx ()
#33 0x08077fc5 in PyEval_EvalCode ()
#34 0x08097e29 in PyRun_FileExFlags ()
#35 0x08096d90 in PyRun_SimpleFileExFlags ()
#36 0x080966da in PyRun_AnyFileExFlags ()
#37 0x08053a19 in Py_Main ()
#38 0x08053469 in main ()
#39 0x400bda07 in __libc_start_main () from /lib/i686/libc.so.6
Comment 1 Brent Fox 2003-08-14 20:17:23 EDT
The backtrace looks like a libuser problem.  Changing components.
Comment 2 Miloslav Trmač 2004-09-02 12:56:31 EDT
Can you please attach or otherwise send me a sample /etc/passwd
file with which this problem occurs, if it still occurs
with a recent release?

Thanks.
Comment 3 Miloslav Trmač 2005-04-17 04:22:44 EDT
Please reopen this report if you can reproduce the problem on a recent release
and you can provide the requested data.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.