Bug 102179 - cmpci.o does not have line1 channel
cmpci.o does not have line1 channel
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-12 06:24 EDT by Paulo Roma Cavalcanti
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:41:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Source code with line 1 added. (103.05 KB, text/plain)
2003-08-12 06:26 EDT, Paulo Roma Cavalcanti
no flags Details

  None (edit)
Description Paulo Roma Cavalcanti 2003-08-12 06:24:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Linux 2.4.20-19.7 i686) Opera 6.12  [en]

Description of problem:

I have an asus motherboard with onboard sound.
Also, I have two cd players. Since there is no line1
available, I can only play music cd's in a single
cdrom.

Incidentally, it is possible to recopile this module 
and add the missing channel (line 1).

I am submiting the source code I use
for your appreciation. I dowloaded it from the 
manufacturer site of the chipset and made some
minor changes to have a smooth compilation.

Thank you.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Just open the mixer. The channel is missing.
2.
3.
   

Actual Results:  No line 1 present.

Expected Results:  I wpoukd expect two have line 1 channel 
as we have when using other sound modules,
as the one for sound blaster.

Additional info:


I think the code I am submting is GPL.
Comment 1 Paulo Roma Cavalcanti 2003-08-12 06:26:59 EDT
Created attachment 93599 [details]
Source code with line 1 added.

 cmpci-5.68 from manufacturer page.
 Fixed compilation for gcc 2.96.
Comment 2 Bugzilla owner 2004-09-30 11:41:26 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.