This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1021812 - Handle conflicts when using @position in declared types
Handle conflicts when using @position in declared types
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: BRE (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: ER5
: 6.0.0
Assigned To: Mario Fusco
Marek Winkler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 03:16 EDT by Mario Fusco
Modified: 2014-08-06 16:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:18:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker DROOLS-249 Minor Resolved Handle conflicts when using @position in declared types 2013-12-12 12:29:56 EST

  None (edit)
Description Mario Fusco 2013-10-22 03:16:36 EDT
declare A
f : int @position(2)
g : int @position(1)
end

declare B extends A
h : int @position(3)
i : int @position(2)
end

The resulting field order may not be deterministic because of

    the clashes (2)
    the missing pos (0)

this is dangerous when used with positional constraints

B( $x, $y, $z, $w ; )
Comment 3 Marek Winkler 2013-12-12 12:33:57 EST
Verified on BRMS 6.0.0 ER5.

Note You need to log in before you can comment on or make changes to this bug.