Bug 1021815 - JGroups: Intermittent failures in LargeStateTransferTest
JGroups: Intermittent failures in LargeStateTransferTest
Status: CLOSED NOTABUG
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Clustering (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity low
: ---
: EAP 6.3.0
Assigned To: Richard Achmatowicz
Jitka Kozana
Russell Dickenson
JGroups testsuite
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 03:18 EDT by Richard Janík
Modified: 2014-10-25 08:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-27 10:35:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Janík 2013-10-22 03:18:31 EDT
Description of problem:

EAP 6.2.0.ER6
JGroups 3.2.12.Final

Note: I have seen this in some previous versions as well and was looking into it:

UDP variants of org.jgroups.tests.LargeStateTransferTest.testStateTransferX often fail with:

Error Message

requester view is [requester|0] [requester], but should have 2 members

Stacktrace


java.lang.AssertionError 
at org.jgroups.tests.LargeStateTransferTest._testStateTransfer(LargeStateTransferTest.java:82) 
at org.jgroups.tests.LargeStateTransferTest.testStateTransfer1(LargeStateTransferTest.java:57) 
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) 
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) 
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) 
at java.lang.reflect.Method.invoke(Method.java:597) 
at org.testng.internal.MethodInvocationHelper.invokeMethod(MethodInvocationHelper.java:80) 
at org.testng.internal.InvokeMethodRunnable.runOne(InvokeMethodRunnable.java:46) 
at org.testng.internal.InvokeMethodRunnable.run(InvokeMethodRunnable.java:37) 
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:439) 
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303) 
at java.util.concurrent.FutureTask.run(FutureTask.java:138) 
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895) 
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918) 
at java.lang.Thread.run(Thread.java:662) 

The issue is not in JGroups, but rather in the testsuite and it has already been fixed in upstream so component upgrades will solve this in time.
Comment 1 Richard Achmatowicz 2014-03-27 10:33:13 EDT
NOTE: A number of EAP clustering issues relate to failures in the JGroups testsuite. Some of these failures relate to tests of features of JGroups which are not used by EAP.

As of EAP 6.3, a modified version of the JGroups testsuite (JGroups version 3.2.13) is being executed which excludes tests of JGroups features which are not used by EAP. Only the testsuite has been modified/fixed; the product is unchanged. The list of features can be found here: https://mojo.redhat.com/docs/DOC-938761

EAP 6.3 Clustering issues relating to failures in the JGroups testsuite are being closed if they relate to features not used by EAP.

Note You need to log in before you can comment on or make changes to this bug.