Bug 1021836 - Zend apps become inaccessible(error 500) after several builds with hot_deploy marker
Zend apps become inaccessible(error 500) after several builds with hot_deploy...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Andy Goldstein
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 04:03 EDT by Zhe Wang
Modified: 2015-05-14 19:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 22:26:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhe Wang 2013-10-22 04:03:30 EDT
Description of problem:
Given a Zend app with hot_deploy marker added, after several builds (usually two rounds of builds), the app becomes inaccessible, returnning 500 error when checking the HTTP status.

Version-Release number of selected component (if applicable):
devenv_3927

How reproducible:
always

Steps to Reproduce:
1. create a zend app
2. create a hot_deploy marker and trigger a build
3. check the availability of the app's homepage
4. make another change and trigger a second build
5. check the availability of the app again
6. repeat Step 4 and 5 several times

Actual results:
The app was accessible in Step 3, but in Step 5 its homepage became blank, returning error 500 when checking the header of the response.

Expected results:
The zend app should be always accessible after several builds with hot_deploy marker.


Additional info:
Comment 1 Dan Mace 2013-10-23 10:49:11 EDT
Seems to be resolved as of devenv_3934.
Comment 2 Zhe Wang 2013-10-24 04:34:27 EDT
Verified in devenv_3837.

Note You need to log in before you can comment on or make changes to this bug.