Bug 1021853 - Display overlaps when the length of authorization note is too long.
Display overlaps when the length of authorization note is too long.
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Robb Hamilton
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 04:31 EDT by Yujie Zhang
Modified: 2015-05-14 21:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-19 13:34:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
display overlaps (106.54 KB, image/png)
2013-10-22 04:31 EDT, Yujie Zhang
no flags Details
display overlaps on authorization details page (57.60 KB, image/png)
2013-10-23 01:17 EDT, Yujie Zhang
no flags Details
long note still overlaps on details page (34.36 KB, image/png)
2013-11-13 22:17 EST, Yujie Zhang
no flags Details

  None (edit)
Description Yujie Zhang 2013-10-22 04:31:03 EDT
Created attachment 814903 [details]
display overlaps

Description of problem:

Created an authorization and add note for it like "QQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQ", and the display overlaps, details see in attachment please.

Version-Release number of selected component (if applicable):

devenv_3925

How reproducible:
always

Steps to Reproduce:
1.Create an authorization 
2.Add note with long length for the authorization
3.

Actual results:

The display overlaps when the length of note is long.

Expected results:

The display should be correct when the length of note is long.

Additional info:
Comment 1 Robb Hamilton 2013-10-22 16:04:26 EDT
Added new table class to fix bug and applied as needed, plus addtional table cleanup I discovered in the process of fixing the bug.

https://github.com/openshift/origin-server/pull/3961
https://github.com/openshift/li/pull/2024
Comment 2 openshift-github-bot 2013-10-22 19:20:31 EDT
Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/51841201e60aa49bd4f758567fed63cccd693ce1
Bug 1021853: adding .table-fixed to address the bug and adding it to the needed tables, misc table cleanup
Comment 3 openshift-github-bot 2013-10-22 19:20:33 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/edce9b71bc6f087f71657d32c61445a46b59594a
Bug 1021853: adding .table-fixed to address the bug and adding it to the needed tables, misc table cleanup
Comment 4 Yujie Zhang 2013-10-23 01:17:00 EDT
(In reply to Robb Hamilton from comment #1)
hi Robb, tested this issue on devenv_3932, the display of long authorization note on settings page is corrected now, but the display of long note still overlaps on the authorization details page after clicking the note link on the settings page, details see in attachment, can you please also fix this? Thanks!
Comment 5 Yujie Zhang 2013-10-23 01:17:48 EDT
Created attachment 815222 [details]
display overlaps on authorization details page
Comment 6 Steve Goodwin 2013-11-13 15:33:40 EST
I believe this bug has been fixed on the authorization details page. Please review.
Comment 7 Yujie Zhang 2013-11-13 22:16:37 EST
(In reply to Steve Goodwin from comment #6)
Tested on devenv_4030, long authorization note still overlaps, need to wrap the long string, details see in attachment please.
Comment 8 Yujie Zhang 2013-11-13 22:17:22 EST
Created attachment 823736 [details]
long note still overlaps on details page
Comment 9 Steve Goodwin 2013-11-19 13:34:32 EST
This issue is unique to Firefox, where <p> within <fieldsets> aren't wrapping. To fix this would require setting the p or it's parent to a fixed width, which would cause problems at mobile resolutions. Or we could give it word-break: break-all but that could cause normal words to break incorrectly. 

Because of these issues and since it's an low severity, isolated case; the decision is to not fix.

Note You need to log in before you can comment on or make changes to this bug.