Bug 1021859 - $JBOSS_HOME contains hidden ".installation" folder after installation
$JBOSS_HOME contains hidden ".installation" folder after installation
Status: CLOSED NOTABUG
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Installer (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Francisco Canas
Petr Kremensky
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 04:40 EDT by Petr Kremensky
Modified: 2014-09-03 00:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-24 01:56:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Kremensky 2013-10-22 04:40:49 EDT
Description of problem:
 There is empty hidden folder left by installer inside $JBOSS_HOME.

Version-Release number of selected component (if applicable):
 EAP 6.2.0.ER6

How reproducible:
 Always

Steps to Reproduce:
 1. Install EAP using default values
 2. Navigate to $JBOSS_HOME
 3. Run: ll -a

Actual results:
EAP-6.2.0/jboss-eap-6.2]$ ll -a
...
drwxrwxr-x.  2 pkremens pkremens   4096 Oct 22 10:36 icons
drwxrwxr-x.  2 pkremens pkremens   4096 Oct 22 10:36 .installation
-rw-rw-r--.  1 pkremens pkremens    425 Oct 15 20:30 JBossEULA.txt

Expected results:
 .installation folder was deleted by installer.
Comment 1 Francisco Canas 2013-10-23 14:02:30 EDT
This hidden directory is not actually left by the installer. It is present in the eap zip. You can verify that by downloading the zip directly from here:
http://download.eng.bos.redhat.com/devel/candidates/JBEAP/JBEAP-6.2.0.ER6/

The installer should only remove folders that it itself put down, otherwise there is a risk (if small) of destroying user data. What options do we have? Should this BZ be reassigned to the team producing the zips?
Comment 2 Petr Kremensky 2013-10-24 01:56:34 EDT
I found out that this directory is here because of new patching mechanism. Sorry for confusion. 

Closing as NOTABUG.

[1] - http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6.2/html/Installation_Guide/sect-Patch_Installation.html

Note You need to log in before you can comment on or make changes to this bug.