Bug 102187 - /etc/zprofile does not source /etc/profile.d/*.sh
/etc/zprofile does not source /etc/profile.d/*.sh
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux Beta
Classification: Retired
Component: zsh (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-12 08:54 EDT by KELEMEN Péter
Modified: 2007-04-18 12:56 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.2.0-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-20 02:31:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description KELEMEN Péter 2003-08-12 08:54:33 EDT
Description of problem:
zsh(1) processes /etc/zprofile startup script when invoked as zsh
(i.e., not in sh(1)/ksh(1)/bash(1) compatibility mode).  Since the
infrastructure to source /etc/profile.d/*.sh package-specific startup
scripts exists only in /etc/profile, zsh(1) users will not benefit
from having those.

Version-Release number of selected component (if applicable):
zsh-4.0.7-1.1

How reproducible:
every time

Steps to Reproduce:
1. strace -f zsh 2>&1 | grep -i profile
    
Actual results:


Expected results:


Additional info:
Include (at least) the /etc/profile.d/*.sh sourcing snippet from
/etc/profile .  However, for the sake of similar environments, just
source /etc/profile from /etc/zprofile...
Comment 1 Jens Petersen 2003-09-03 23:17:18 EDT
Can you explain in more detail how to reproduce this, please?

I see:

% strace -f zsh -l | grep profile
stat64("/etc/zprofile.zwc", 0xbfffdb50) = -1 ENOENT (No such file or directory)
stat64("/etc/zprofile", {st_mode=S_IFREG|0644, st_size=146, ...}) = 0
open("/etc/zprofile", O_RDONLY|O_NOCTTY|O_LARGEFILE) = 3
read(11, "#\n# /etc/zprofile and ~/.zprofil"..., 4096) = 146
stat64("/home/petersen/.zprofile.zwc", 0xbfffd970) = -1 ENOENT (No such file or
directory)
stat64("/home/petersen/.zprofile", 0xbfffd910) = -1 ENOENT (No such file or
directory)
open("/home/petersen/.zprofile", O_RDONLY|O_NOCTTY|O_LARGEFILE) = -1 ENOENT (No
such file or directory)
stat64("/etc/profile", {st_mode=S_IFREG|0644, st_size=842, ...}) = 0
access("/etc/profile", F_OK)            = 0
stat64("/etc/profile", {st_mode=S_IFREG|0644, st_size=842, ...}) = 0
stat64("/etc/profile.zwc", 0xbfffd270)  = -1 ENOENT (No such file or directory)
stat64("/etc/profile", {st_mode=S_IFREG|0644, st_size=842, ...}) = 0
open("/etc/profile", O_RDONLY|O_NOCTTY|O_LARGEFILE) = 3
read(12, "# /etc/profile\n\n# System wide en"..., 4096) = 842
open("/etc/profile.d/", O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY) = 3
access("/etc/profile.d/colorls.sh", R_OK) = 0
stat64("/etc/profile.d/colorls.sh.zwc", 0xbfffc8c0) = -1 ENOENT (No such file or
directory)
stat64("/etc/profile.d/colorls.sh", {st_mode=S_IFREG|0755, st_size=719, ...}) =
0
:
:
Comment 2 Jens Petersen 2003-09-04 02:32:42 EDT
Nevermind.  Please include /etc/shell/.zshrc in your .zshrc file.

*** This bug has been marked as a duplicate of 88457 ***
Comment 3 Jens Petersen 2004-07-05 03:44:45 EDT
*** Bug 126539 has been marked as a duplicate of this bug. ***
Comment 4 Jens Petersen 2004-07-05 03:46:45 EDT
Going to try out sourcing profile in zprofile in 4.2.0-3.
Comment 5 Daniel Qarras 2007-01-31 00:10:21 EST
I posted something related to bug 126539 and but bug 225454. It seems that I
cannot reopen this one.
Comment 6 Matěj Cepl 2007-01-31 15:55:20 EST
*** Bug 226344 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.