Bug 1021882 - GlusterFS mount succeeded and exists although the create storage domain failed
GlusterFS mount succeeded and exists although the create storage domain failed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Daniel Erez
Aharon Canan
storage
:
Depends On:
Blocks: 3.3snap2
  Show dependency treegraph
 
Reported: 2013-10-22 05:19 EDT by Aharon Canan
Modified: 2016-02-10 13:50 EST (History)
10 users (show)

See Also:
Fixed In Version: is23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:19:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amureini: Triaged+


Attachments (Terms of Use)
logs (6.41 MB, application/x-gzip)
2013-10-22 05:19 EDT, Aharon Canan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20726 None None None Never
oVirt gerrit 20945 None None None Never

  None (edit)
Description Aharon Canan 2013-10-22 05:19:52 EDT
Created attachment 814915 [details]
logs

Description of problem:
GlusterFS mount succeeded and exists although the create storage doamin failed becuase we use path which was in use previously and includes data

Version-Release number of selected component (if applicable):
is19

How reproducible:
100%

Steps to Reproduce:
1. Create glusterFS storage domain using path that was in use previously and includes data


Actual results:
create new glusterSD fails (good) but as we already mount to check the mount remains in the host and we can't clean data and recreate the SD without manually umount.

Expected results:
in case create glusterFS SD fails we need to umount it from host.

Additional info:
===========
[root@camel-vdsb /]# date
Tue Oct 22 12:17:31 IDT 2013
[root@camel-vdsb /]# mount
/dev/mapper/vg0-lv_root on / type ext4 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw,rootcontext="system_u:object_r:tmpfs_t:s0")
/dev/sda1 on /boot type ext4 (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
10.35.161.249:/acanan01 on /rhev/data-center/mnt/glusterSD/10.35.161.249:_acanan01 type fuse.glusterfs (rw,default_permissions,allow_other,max_read=131072)
Comment 1 Allon Mureinik 2013-10-23 04:09:50 EDT
How is the SD created?
GUI? REST? doesn't matter?
Comment 2 Aharon Canan 2013-10-23 04:12:41 EDT
GUI
Comment 3 Allon Mureinik 2013-10-27 04:56:02 EDT
probably a dup of bug 1020812.
Daniel - please take a look?
Comment 4 Aharon Canan 2013-11-14 10:24:58 EST
verified using is23
Comment 5 Charlie 2013-11-27 19:35:13 EST
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 6 errata-xmlrpc 2014-01-21 11:19:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.