Bug 1021902 - hosted-engine --add-console-password should have interactive option
hosted-engine --add-console-password should have interactive option
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup (Show other bugs)
3.3.0
Unspecified Unspecified
high Severity high
: ---
: 3.3.0
Assigned To: Yedidyah Bar David
Leonid Natapov
integration
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 06:05 EDT by movciari
Modified: 2014-01-21 11:54 EST (History)
7 users (show)

See Also:
Fixed In Version: ovirt-hosted-engine-setup-1.0.0-0.10.1.rc.el6ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:54:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21453 None None None Never
oVirt gerrit 21498 None None None Never

  None (edit)
Description movciari 2013-10-22 06:05:23 EDT
Description of problem:
when you want to set console password, you have to write it in commandline option, like "hosted-engine --add-console-password=badpassword"

there should be an option to input password interactively, so it doesn't stay in bash history, scrollback buffer of screen or anywhere else, for example "hosted-engine --add-console-password --interactive"

Version-Release number of selected component (if applicable):
is19

How reproducible:
always

Steps to Reproduce:
1. hosted-engine --help
2. use --add-console-password as you see it in help

Actual results:


Expected results:


Additional info:
Comment 1 Itamar Heim 2013-10-23 02:01:22 EDT
please use same logic as all other utilities for password handling
Comment 2 Sandro Bonazzola 2013-10-23 02:50:31 EDT
I think it should be only interactive, using an env var to allow you to automate process for testing if really needed.
Comment 3 Yedidyah Bar David 2013-11-20 05:33:12 EST
vdsClient only accepts a password on the command line, so we'll pass it to it this way anyway and it will be seen with 'ps'. Do we want to also make vdsClient accept passwords using other means?
Comment 4 Sandro Bonazzola 2013-11-20 05:44:46 EST
(In reply to Yedidyah Bar David from comment #3)
> vdsClient only accepts a password on the command line, so we'll pass it to
> it this way anyway and it will be seen with 'ps'. Do we want to also make
> vdsClient accept passwords using other means?

I think it should. Please open a BZ about it on vdsm, we'll update hosted-engine code when they'll fix it. 

For now, let's fix this on our command line.
Comment 5 Dan Kenigsberg 2013-11-20 06:45:56 EST
Please avoid using the vdsClient command line. It's broken in so many forms. Since hosted-engine is a python app, importing vdsm.vdscli and using it to contact the running vdsm process is much more robust.
Comment 6 Yedidyah Bar David 2013-11-20 07:00:24 EST
(In reply to Dan Kenigsberg from comment #5)
> Please avoid using the vdsClient command line. It's broken in so many forms.
> Since hosted-engine is a python app, importing vdsm.vdscli and using it to
> contact the running vdsm process is much more robust.

Actually hosted-engine is a shell script. Only ovirt-hosted-engine-setup, which is called by '--deploy', is a python app.
Comment 7 Sandro Bonazzola 2013-11-21 08:45:05 EST
Patches merged on upstream master and 1.0 branches.
Comment 9 Leonid Natapov 2013-12-09 10:43:09 EST
is26. fixed.
Comment 10 errata-xmlrpc 2014-01-21 11:54:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0083.html

Note You need to log in before you can comment on or make changes to this bug.