Bug 1021947 - segfault on creating bond device
segfault on creating bond device
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: NetworkManager (Show other bugs)
6.5
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Jirka Klimes
Desktop QE
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 07:44 EDT by Tomas Pelka
Modified: 2016-01-04 01:03 EST (History)
4 users (show)

See Also:
Fixed In Version: NetworkManager-0.8.1-66.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 16:51:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nm log (16.45 KB, text/plain)
2013-10-22 07:44 EDT, Tomas Pelka
no flags Details
more readable backtrace (10.39 KB, text/plain)
2013-10-22 08:30 EDT, Tomas Pelka
no flags Details
[PATCH] ifcfg-rh: do not exit on invalid assertion (bond slave has IP setting) (3.83 KB, patch)
2013-10-22 09:55 EDT, Jirka Klimes
no flags Details | Diff

  None (edit)
Description Tomas Pelka 2013-10-22 07:44:47 EDT
Created attachment 814948 [details]
nm log

Description of problem:


Version-Release number of selected component (if applicable):
NetworkManager-0.8.1-63.el6

How reproducible:
100%

Steps to Reproduce:
1. Create new bond profile
2. add first slave
3. fill in correct HW address 

Actual results:
NM wrote the ifcfg-bond0_slave_1 but than segfaults

# cat ifcfg-bond0_slave_1 
TYPE=Ethernet
NAME="bond0 slave 1"
UUID=33f61793-363c-402d-b0b3-7c11a23631fd
ONBOOT=no
MASTER=4faf8a54-5124-46ce-9edf-0912cc40e214
HWADDR=52:54:00:69:00:C9


Expected results:
no segfault

Additional info:
Comment 1 Tomas Pelka 2013-10-22 08:30:29 EDT
Created attachment 814967 [details]
more readable backtrace
Comment 2 Jirka Klimes 2013-10-22 09:55:49 EDT
Created attachment 815013 [details]
[PATCH] ifcfg-rh: do not exit on invalid assertion (bond slave has IP setting)

Patch for RHEL-6.5 to fix crashing NM when saving a bond slave connection into ifcfg file.
Comment 8 errata-xmlrpc 2013-11-21 16:51:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1670.html

Note You need to log in before you can comment on or make changes to this bug.