This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1021949 - Quota + Rebalance : Able to create files beyond the quota limit set after add brick and rebalance
Quota + Rebalance : Able to create files beyond the quota limit set after add...
Status: CLOSED DUPLICATE of bug 1002885
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Bug Updates Notification Mailing List
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 07:46 EDT by senaik
Modified: 2015-09-01 08:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-23 02:21:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 senaik 2013-10-22 10:37:34 EDT
Issue seen in glusterfs 3.4.0.35rhs

Repeated the same steps as mentioned in Description above , able to create files upto 3.1GB when hard limit is set to 1GB 

[root@boost ~]# gluster v quota test list /dir1
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/dir1                                      1.0GB       80%       3.1GB  0Bytes

 gluster v i test
 
Volume Name: test
Type: Distributed-Replicate
Volume ID: 7365ae59-ad1e-4ccd-8e82-a9377b957a3c
Status: Started
Number of Bricks: 3 x 2 = 6
Transport-type: tcp
Bricks:
Brick1: 10.70.34.86:/rhs/brick1/e1
Brick2: 10.70.34.85:/rhs/brick1/e2
Brick3: 10.70.34.88:/rhs/brick1/e3
Brick4: 10.70.34.89:/rhs/brick1/e4
Brick5: 10.70.34.89:/rhs/brick1/e5
Brick6: 10.70.34.86:/rhs/brick1/e6
Options Reconfigured:
features.quota: on


getfattr -d -m . -e hex /rhs/brick1/e1/dir1/
getfattr: Removing leading '/' from absolute path names
# file: rhs/brick1/e1/dir1/
trusted.gfid=0x50e4115ee9c142c5ac6b4d3a99c7f685
trusted.glusterfs.dht=0x000000010000000055555555aaaaaaa9
trusted.glusterfs.quota.00000000-0000-0000-0000-000000000001.contri=0x0000000014e80000
trusted.glusterfs.quota.dirty=0x3000
trusted.glusterfs.quota.limit-set=0x0000000040000000ffffffffffffffff
trusted.glusterfs.quota.size=0x0000000014e80000



getfattr -d -m . -e hex /rhs/brick1/e2/dir1/
getfattr: Removing leading '/' from absolute path names
# file: rhs/brick1/e2/dir1/
trusted.gfid=0x50e4115ee9c142c5ac6b4d3a99c7f685
trusted.glusterfs.dht=0x000000010000000055555555aaaaaaa9
trusted.glusterfs.quota.00000000-0000-0000-0000-000000000001.contri=0x0000000014e80000
trusted.glusterfs.quota.dirty=0x3000
trusted.glusterfs.quota.limit-set=0x0000000040000000ffffffffffffffff
trusted.glusterfs.quota.size=0x0000000014e80000


getfattr -d -m . -e hex /rhs/brick1/e3/dir1/getfattr: Removing leading '/' from absolute path names
# file: rhs/brick1/e3/dir1/
trusted.gfid=0x50e4115ee9c142c5ac6b4d3a99c7f685
trusted.glusterfs.dht=0x00000001000000000000000055555554
trusted.glusterfs.quota.00000000-0000-0000-0000-000000000001.contri=0x0000000013600000
trusted.glusterfs.quota.dirty=0x3000
trusted.glusterfs.quota.limit-set=0x0000000040000000ffffffffffffffff
trusted.glusterfs.quota.size=0x0000000013600000


getfattr -d -m . -e hex /rhs/brick1/e4/dir1/getfattr: Removing leading '/' from absolute path names
# file: rhs/brick1/e4/dir1/
trusted.gfid=0x50e4115ee9c142c5ac6b4d3a99c7f685
trusted.glusterfs.dht=0x00000001000000000000000055555554
trusted.glusterfs.quota.00000000-0000-0000-0000-000000000001.contri=0x0000000013600000
trusted.glusterfs.quota.dirty=0x3000
trusted.glusterfs.quota.limit-set=0x0000000040000000ffffffffffffffff
trusted.glusterfs.quota.size=0x0000000013600000


getfattr -d -m . -e hex /rhs/brick1/e5/dir1/
getfattr: Removing leading '/' from absolute path names
# file: rhs/brick1/e5/dir1/
trusted.gfid=0x50e4115ee9c142c5ac6b4d3a99c7f685
trusted.glusterfs.dht=0x0000000100000000aaaaaaaaffffffff
trusted.glusterfs.quota.00000000-0000-0000-0000-000000000001.contri=0x00000000a0a00000
trusted.glusterfs.quota.dirty=0x3000
trusted.glusterfs.quota.size=0x00000000a0a00000


getfattr -d -m . -e hex /rhs/brick1/e6/dir1/
getfattr: Removing leading '/' from absolute path names
# file: rhs/brick1/e6/dir1/
trusted.gfid=0x50e4115ee9c142c5ac6b4d3a99c7f685
trusted.glusterfs.dht=0x0000000100000000aaaaaaaaffffffff
trusted.glusterfs.quota.00000000-0000-0000-0000-000000000001.contri=0x00000000a0a00000
trusted.glusterfs.quota.dirty=0x3000
trusted.glusterfs.quota.size=0x00000000a0a00000
Comment 3 senaik 2013-10-23 02:21:57 EDT

*** This bug has been marked as a duplicate of bug 1002885 ***

Note You need to log in before you can comment on or make changes to this bug.