Bug 1021962 - Role - different id in request and response
Role - different id in request and response
Status: CLOSED UPSTREAM
Product: Pulp
Classification: Community
Component: API/integration (Show other bugs)
2.2
Unspecified Unspecified
low Severity unspecified
: ---
: 3.0.0
Assigned To: pulp-bugs
pulp-qe-list
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 08:22 EDT by Pavlina Bartikova
Modified: 2015-02-28 16:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-28 16:59:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Pulp Redmine 380 None None None Never

  None (edit)
Description Pavlina Bartikova 2013-10-22 08:22:11 EDT
Description of problem:
Request for create role expects "role_id", but in response is only "id".

How reproducible:
always

Steps to Reproduce:
1. create role

Actual results:
post role_id
get id

Expected results:
post id
get id

Additional info:
https://pulp-dev-guide.readthedocs.org/en/pulp-2.2/integration/rest-api/role/cud.html
Comment 1 Chris Duryee 2014-11-11 20:19:46 EST
This is still outstanding as of 2.4.3

from server_calls.log when creating a role:

2014-11-12 01:16:19,360 - INFO - POST request to /pulp/api/v2/roles/ with parameters {"display_name": null, "description": null, "role_id": "foo-role"}
2014-11-12 01:16:19,361 - INFO - Response status : 201 

2014-11-12 01:16:19,361 - INFO - Response body :
 {
  "display_name": "foo-role", 
  "description": null, 
  "_ns": "roles", 
  "permissions": {}, 
  "_id": {
    "$oid": "5462b4e3d7a7470368373223"
  }, 
  "id": "foo-role", 
  "_href": "/pulp/api/v2/roles/foo-role/"
}

Assigning this to 3.0.0 since that is our next opportunity to fix this.
Comment 2 Brian Bouterse 2015-02-28 16:59:32 EST
Moved to https://pulp.plan.io/issues/380

Note You need to log in before you can comment on or make changes to this bug.