Bug 1021981 - Anaconda uses English (United Kingdom) as default. This will pick UK keyboard for console.
Anaconda uses English (United Kingdom) as default. This will pick UK keyboard...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 08:42 EDT by Marian Csontos
Modified: 2013-10-22 11:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-22 09:34:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marian Csontos 2013-10-22 08:42:28 EDT
Description of problem:
By default UK layout is used. I strongly believe US layout is much more sensible for majority of users - at least a large majority of US residents and a majority of non-UK residents who chose English languages.

And as second pinned language (the languages above the line) some gibberish is used (Oh sorry, that's politically incorrect flame bait! It is Cymraeg which looks like gibberish to most of users IMHO.) Why not Klingon or Elvish language which are much more obscure?

I suggest some sensible default like: Russian, Chinese or Spanish which have much larger populations and LATAM region is active in Fedora too?

I suggest to use some sort of data to select them:

The most relevant may be: http://en.wikipedia.org/wiki/Languages_used_on_the_Internet

Or http://en.wikipedia.org/wiki/List_of_languages_by_number_of_native_speakers
Or http://en.wikipedia.org/wiki/List_of_languages_by_total_number_of_speakers
Or some other metric.

I checked LC_ALL is C, no other locales in the env.

Version-Release number of selected component (if applicable):
anaconda-20.25-1
HW: I am using qemu-kvm VMs created with virt-install.

How reproducible:
100%

Steps to Reproduce:
1. default anaconda install

Actual results:
English > English (United Kingdom)

Expected results:
English > English (United States)

Additional info:
changing to another language (e.g the mention Cymraeg) and back, US English is correctly picked.
Comment 1 David Shea 2013-10-22 09:34:58 EDT
The default language and keyboard layout are chosen based on GeoIP information. If you believe there is a problem with the location detection, re-open the bug and attach the log files from /tmp.

Beyond the automatically detected choices, all other available languages are listed alphabetically based on their English translation. The list is searchable both by the English translation and by the native name for the language.
Comment 2 Marian Csontos 2013-10-22 11:41:07 EDT
I have found where GeoIP is used, but there is nothing in particular about the location it assumes. That would be corp network issue then... :-/

Thanks.

-- Martian

Note You need to log in before you can comment on or make changes to this bug.