Bug 1021982 - [RHSC] - Remove brick warning for distributed replicate volume has an extra parameter which is not relevant . [NEEDINFO]
[RHSC] - Remove brick warning for distributed replicate volume has an extra p...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: Timothy Asir
RamaKasturi
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 08:43 EDT by RamaKasturi
Modified: 2015-05-13 12:26 EDT (History)
3 users (show)

See Also:
Fixed In Version: cb9
Doc Type: Bug Fix
Doc Text:
Previously, the warning displayed during Remove Brick operation had irrelevant characters. Now, with this update, the Remove Brick warning text error is corrected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:43:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sharne: needinfo? (tjeyasin)


Attachments (Terms of Use)
Attaching the screen shot for the warning message when trying to remove a single brick from distribute replicate volume. (194.93 KB, image/png)
2013-11-26 06:11 EST, RamaKasturi
no flags Details

  None (edit)
Description RamaKasturi 2013-10-22 08:43:36 EDT
Description of problem:
Remove brick warning for distributed replicate volume has an extra parameter which is not relevant .

Version-Release number of selected component (if applicable):
rhsc-2.1.2-0.0.scratch.beta1.el6_4.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create a distribute replicate volume 
2. Now go to the bricks tab and click on the bricks sub tab.
3. select one brick and click on remove.

Actual results:
It displays a warning dialog box with the following message "Incorrect bricks selected for removal in Distributed Replicate volume. <br/> Either all the selected bricks should be from the same sub volume or one brick each for every sub volume!
10.70.37.166:/rhs/brick2/b1"

Expected results:
<br/> should be removed from the message.

Additional info:
Comment 2 RamaKasturi 2013-11-26 06:10:11 EST
Verified in CB9 (rhsc-2.1.2-0.25.master.el6_5.noarch). Now message does not have any extra parameters. 

Attaching the screenshot for the same.
Comment 3 RamaKasturi 2013-11-26 06:11:13 EST
Created attachment 829195 [details]
Attaching the screen shot for the warning message when trying to remove a single brick from distribute replicate volume.
Comment 4 Shalaka 2014-01-13 04:29:41 EST
Please review the edited DocText and signoff.
Comment 6 errata-xmlrpc 2014-02-25 02:43:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.