Bug 1022009 - response times not shown for managed deployment
response times not shown for managed deployment
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6 (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity high
: DR01
: JON 3.3.0
Assigned To: Libor Zoubek
Filip Brychta
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 09:32 EDT by Libor Zoubek
Modified: 2015-11-01 19:43 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-11 09:00:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2013-10-22 09:32:56 EDT
Description of problem: Agent is not able to show response times for managed deployment. It looks like it is not able to detect path to rt filter log file and it only applies to managed servers added via JON. Reading rt log files works as expected for stock managed servers


Version-Release number of selected component (if applicable):
JON 3.2.ER3

How reproducible: always


Steps to Reproduce:
1. have EAP6 running in domain mode with installed rt-filter subsystem and module or war app including rt filter
2. deploy such app as DomainDeployment, then promote this deployment to all server groups
3. add new managed server to any group, start it up, wait for discovery
4. enable calltime metric once ManagedDeployment gets discovered on your new server
5. send hits to your apps (at least 11, so you're sure rtFilter wrote it to file)
6. check calltime metric for past 8 hours in JON UI
 
Actual results:
no data

agent log repeats this message (based on interval you set to calltime metric)

WARN  [ResourceContainer.invoker.daemon-4751] (rhq.core.pluginapi.util.ResponseTimeLogParser)- Response-time log
file '/home/hudson/jboss-eap6-domain/domain/log/rt/hello_rt.log' does not exist.


Expected results:

you should see values in UI, no warning in agent log

Additional info:
Comment 2 Libor Zoubek 2014-07-02 16:00:22 EDT
in master

commit ddd51b089d2bbd4410d5c51aad9e3713cd24d737
Author: Libor Zoubek <lzoubek@redhat.com>
Date:   Wed Jul 2 21:44:14 2014 +0200

    [BZ 1022009] - response times not shown for managed deployment
    
    Fixed the way we resolve server log dir in case the deployment is on managed
    server
Comment 3 Simeon Pinder 2014-07-31 11:51:29 EDT
Moving to ON_QA as available to test with brew build of DR01: https://brewweb.devel.redhat.com//buildinfo?buildID=373993
Comment 4 Filip Brychta 2014-08-08 05:17:32 EDT
Verified on
Version :	
3.3.0.DR01
Build Number :	
6468454:dda0a47

Note You need to log in before you can comment on or make changes to this bug.