Bug 1022021 - RHEVM 3.2 vdsm on RHEL host does not survive host upgrade from RHEL 6.4 to RHEL 6.5 (libvirtError: internal error client socket is closed)
RHEVM 3.2 vdsm on RHEL host does not survive host upgrade from RHEL 6.4 to RH...
Status: CLOSED DUPLICATE of bug 958367
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.2.0
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: lpeer
Martin Pavlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 09:53 EDT by Martin Pavlik
Modified: 2015-04-06 23:11 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-22 10:10:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sos_reoprt_from_node (5.92 MB, application/x-xz)
2013-10-22 09:53 EDT, Martin Pavlik
no flags Details
engine logs (95.96 KB, application/gzip)
2013-10-22 09:55 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2013-10-22 09:53:17 EDT
Created attachment 815010 [details]
sos_reoprt_from_node

Description of problem:
After putting RHEL 6.4 host to maintenance, updating it to RHEL 6.5 via yum update, it is not possible to activate the host. Host is in unassigned state.

it seems that problem might be caused by updating libvirt package during the process

 libvirt                                           x86_64    0.10.2-29.el6                          rhel65-brq                      2.3 M
 libvirt-client                                    x86_64    0.10.2-29.el6                          rhel65-brq                      4.0 M
 libvirt-lock-sanlock                              x86_64    0.10.2-29.el6                          rhel65-optional-brq             170 k
 libvirt-python                                    x86_64    0.10.2-29.el6                          rhel65-brq                      475 k

vdsm is not able to connect to libvirt upon host activation

Thread-79::ERROR::2013-10-22 14:32:25,885::BindingXMLRPC::923::vds::(wrapper) libvirt error
Traceback (most recent call last):
  File "/usr/share/vdsm/BindingXMLRPC.py", line 918, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/BindingXMLRPC.py", line 287, in getCapabilities
    ret = api.getCapabilities()
  File "/usr/share/vdsm/API.py", line 1119, in getCapabilities
    c = caps.get()
  File "/usr/share/vdsm/caps.py", line 279, in get
    caps.update(netinfo.get())
  File "/usr/lib64/python2.6/site-packages/vdsm/netinfo.py", line 349, in get
    nets = networks()
  File "/usr/lib64/python2.6/site-packages/vdsm/netinfo.py", line 150, in networks
    for name in conn.listNetworks():
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 3433, in listNetworks


Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: 3.2.4-0.44.el6ev

How reproducible:
100%

Steps to Reproduce:
1. add RHEL 6.4 host into RHEV-M 3.2 (sf21.1)
2. put host into maintenance
3. add RHEL 6.5 repos to the host and run yum update
4. activate the host

Actual results:
host cannot be activated due to libvirt error

Expected results:
host can be activated after RHEL upgrade

Additional info:
restarting vdsmd fixes the issue
Comment 1 Martin Pavlik 2013-10-22 09:55:36 EDT
Created attachment 815012 [details]
engine logs
Comment 2 Martin Pavlik 2013-10-22 10:10:04 EDT

*** This bug has been marked as a duplicate of bug 958367 ***

Note You need to log in before you can comment on or make changes to this bug.