Bug 1022046 - [ovirt-guest-agent] /bin/systemctl daemon-reload in RHEL rpm scripts (postinstall)
[ovirt-guest-agent] /bin/systemctl daemon-reload in RHEL rpm scripts (postins...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-guest-agent (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: 3.3.0
Assigned To: Vinzenz Feenstra [evilissimo]
Ilanit Stein
virt
:
Depends On:
Blocks: 3.3snap2
  Show dependency treegraph
 
Reported: 2013-10-22 10:31 EDT by Jiri Belka
Modified: 2014-01-21 10:52 EST (History)
8 users (show)

See Also:
Fixed In Version: is22
Doc Type: Bug Fix
Doc Text:
This update removes the /bin/systemctl daemon-reload call, which is required for systemd in Red Hat Enterprise Linux postinstall scripts, but not for the ovirt-guest-agent.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 10:52:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Belka 2013-10-22 10:31:04 EDT
Description of problem:
RHEL GA rpm contains systemctl commands in (rpm) scriplet:

    51  postuninstall scriptlet (using /bin/sh):
    52  if [ "$1" -eq 0 ]
    53  then
    54      /bin/systemctl daemon-reload
    55      # Let udev clear access rights
    56      /sbin/udevadm trigger --subsystem-match="virtio-ports" \
    57          --attr-match="name=com.redhat.rhevm.vdsm"
    58  fi
    59  
    60  if [ "$1" -ge 1 ]; then
    61      /sbin/service ovirt-guest-agent condrestart > /dev/null 2>&1
    62  fi

Current RHEL 6.x does not have magnificent systemd.

Version-Release number of selected component (if applicable):
rhevm-guest-agent-common-1.0.8-4

How reproducible:
100%

Steps to Reproduce:
1. rpm --scripts -qp $rpm
2.
3.

Actual results:
systemd invasion

Expected results:
not yet, not yet... :D

Additional info:
Comment 3 Ilanit Stein 2013-11-05 07:14:53 EST
Verified on is21 + install rhevm-guest-agent-common-1.0.8-5.

Checked  rpm --scripts -q rhevm-guest-agent-common do not contain /bin/systemctl daemon-reload
Comment 5 errata-xmlrpc 2014-01-21 10:52:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0058.html

Note You need to log in before you can comment on or make changes to this bug.