Bug 1022077 - Cloned repository rises an error when selected in the Project Explorer list
Cloned repository rises an error when selected in the Project Explorer list
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Deployment (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity unspecified
: ER5
: 6.0.0
Assigned To: Alexandre Porcelli
Ivo Bek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 11:34 EDT by Michael
Modified: 2014-08-06 16:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:06:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File to see the error (2.18 MB, video/ogg)
2013-10-22 11:34 EDT, Michael
no flags Details

  None (edit)
Description Michael 2013-10-22 11:34:31 EDT
Created attachment 815064 [details]
File to see the error

Description of problem:
A repository can be cloned successfully. But when selecting this repository in the project explorer list an error rises:

Unable to complete your request. The following exception occurred: org.kie.commons.java.nio.base.Properties.

After closing the panel showing this error, it seems to be work fine, until we change again the repository nd re-change it to the cloned repository.

Version-Release number of selected component (if applicable):
JBoss EAP 6.1.1, deployed kie-wb-6.0.0-SNAPSHOT-eap-6_1.war.

How reproducible:
Clone a repository in EAP 6.1.1 and try to access it using the project explorer

Steps to Reproduce:
1. Install a JBoss EAP 6.1.1
2. Clone a repository (https://github.com/mbiarnes/examples.git)
3. Try to access it in the Project Authoring View

Actual results:
An error rises: 
Unable to complete your request. The following exception occurred: org.kie.commons.java.nio.base.Properties.

Expected results:
The GAV should be loaded in the right part of the panel

Additional info:
The log doesn't show any errors.
Comment 2 Alexandre Porcelli 2013-10-23 12:54:25 EDT
The cloned repository was created using an old version of uberfire (the one that still used kie-commons, now kie-commons and uberfire are merged) - so the class org.kie.commons.java.nio.base.Properties doesn't exists.

Our demo repos were updated in order to avoid this issue, so the solution should be the same (update repository).

Here an example of what to do: https://github.com/guvnorngtestuser1/guvnorng-playground/commit/173a15938a558444757cabe4e0fa41ecd9eac839
Comment 3 Ivo Bek 2013-12-13 07:27:10 EST
Verified in BPMS 6.0.0.ER5

Note You need to log in before you can comment on or make changes to this bug.