Bug 1022100 - gettext-commons: remove versioned jars from %{_javadir}
gettext-commons: remove versioned jars from %{_javadir}
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gettext-commons (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: anish
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1022024
  Show dependency treegraph
 
Reported: 2013-10-22 11:42 EDT by Stanislav Ochotnicky
Modified: 2015-04-12 19:12 EDT (History)
2 users (show)

See Also:
Fixed In Version: gettext-commons-0.9.6-10.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-20 22:30:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stanislav Ochotnicky 2013-10-22 11:42:57 EDT
Package gettext-commons seems to contain versioned jar files in %{_javadir}
(/usr/share/java). Such versioned files cause problems for automatic
requires generation and violate packaging guidelines[1].

List of subpackages and contained versioned jars
gettext-commons:
/usr/share/java/gettext-commons-0.9.6.jar


There are cases where this can be a false positive. Most likely if:
   * your package is compatibility version and contains only versioned
     jars
   * your package has version in the name of jars that are part of
     package name

Thank you,

[1] https://fedoraproject.org/wiki/Packaging:Java#Filenames
Comment 1 Fedora Admin XMLRPC Client 2014-01-15 06:02:52 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 anish 2014-01-20 04:27:58 EST
did all above steps but still could not clean my repo

[anish@localhost commit]$ git clone ssh://52aaf3844382ecae8c000409@sentenceit-wwe.rhcloud.com/~/git/sentenceit.git/
Cloning into 'sentenceit'...
remote: Counting objects: 167, done.
error: pack-objects died of signal 951/157)   
error: git upload-pack: git-pack-objects died with error.
remote: aborting due to possible repository corruption on the remote side.
fatal: early EOF
fatal: index-pack failed
fatal: git upload-pack: aborting due to possible repository corruption on the remote side.
Comment 3 anish 2014-01-20 05:21:23 EST
just ingore my previous comment its not related to this issue
Comment 4 Fedora Update System 2014-03-20 06:06:46 EDT
gettext-commons-0.9.6-10.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gettext-commons-0.9.6-10.fc19
Comment 5 Fedora Update System 2014-03-20 06:06:58 EDT
gettext-commons-0.9.6-10.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/gettext-commons-0.9.6-10.fc20
Comment 6 Fedora Update System 2014-03-21 05:32:09 EDT
Package gettext-commons-0.9.6-10.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gettext-commons-0.9.6-10.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-4144/gettext-commons-0.9.6-10.fc20
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2014-05-20 22:30:00 EDT
gettext-commons-0.9.6-10.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2014-05-20 22:32:22 EDT
gettext-commons-0.9.6-10.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.