Bug 102211 - SRPM build fails reporting an undefined reference
SRPM build fails reporting an undefined reference
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: ncurses (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-12 12:17 EDT by Michael Lee Yohe
Modified: 2015-01-07 19:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-13 12:46:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Lee Yohe 2003-08-12 12:17:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030722 Galeon/1.3.7

Description of problem:
Upon performing the final linking, ncurses fails with the following message:

../lib/libncursesw.so: undefined reference to `__builtin_va_start'
collect2: ld returned 1 exit status

I have the following packages installed:

gcc-3.3-14
sharutils-4.2.1-14
glibc-2.3.2-27.9

Version-Release number of selected component (if applicable):
ncurses-5.3-7

How reproducible:
Always

Steps to Reproduce:
1. see description    

Actual Results:  see description

Expected Results:  I would expect a binary RPM to be produced.

Additional info:
Comment 1 Eido Inoue 2003-08-12 12:33:47 EDT
Looks like you have a standard Red Hat Linux 9 updated with errata WITH THE
EXCEPTION of the compiler (current is 3.2.2-5).

Was able to rebuild the package using the supported packages.
Comment 2 Michael Lee Yohe 2003-08-12 13:19:45 EDT
Should there not be a BuildRequires in there somewhere specifying which package
is not the latest and greatest?  I mean, theoretically - if my system passes all
BuildRequires it's supposed to build.
Comment 3 Eido Inoue 2003-08-13 12:46:56 EDT
Your compiler is more recent than the current supported version. As for why it
didn't compile: this could be a bug in the later version of gcc, or it could be
that gcc has gotten "stricter" or more "correct" about linking requirements.

When we support a newer version of gcc, we will ensure that all of our packages
can be built with it.
Comment 4 Eido Inoue 2003-08-13 12:54:20 EDT
> I mean, theoretically - if my system passes all BuildRequires it's supposed to
build.

No-- there far more variables that affect whether or not something will build;
while we try our best to make packages as flexible as possible and build on as
many arches and even distros as possible, there's no way we can QA any package
outside of the "supported environment"-- as the amount of possibilities (flawed
packages from outside sources, etc) to test against would be infinite.

Note You need to log in before you can comment on or make changes to this bug.