Bug 1022116 - jcharts: remove versioned jars from %{_javadir}
jcharts: remove versioned jars from %{_javadir}
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jcharts (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
: Patch, Reopened
Depends On:
Blocks: 1022024
  Show dependency treegraph
 
Reported: 2013-10-22 11:45 EDT by Stanislav Ochotnicky
Modified: 2014-03-27 10:45 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.7.5-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-27 10:45:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Remove version from JAR name (2.53 KB, patch)
2014-03-25 04:57 EDT, Michael Simacek
no flags Details | Diff

  None (edit)
Description Stanislav Ochotnicky 2013-10-22 11:45:27 EDT
Package jcharts seems to contain versioned jar files in %{_javadir}
(/usr/share/java). Such versioned files cause problems for automatic
requires generation and violate packaging guidelines[1].

List of subpackages and contained versioned jars
jcharts:
/usr/share/java/jCharts-0.7.5.jar


There are cases where this can be a false positive. Most likely if:
   * your package is compatibility version and contains only versioned
     jars
   * your package has version in the name of jars that are part of
     package name

Thank you,

[1] https://fedoraproject.org/wiki/Packaging:Java#Filenames
Comment 1 Markus Mayer 2013-10-28 15:43:54 EDT
I've just orphand jcharts in rawhide. So setting to WONTFIX
Comment 2 Stanislav Ochotnicky 2013-10-29 04:31:17 EDT
Don't close bugs just because you orphaned a package. It's still a bug that needs to be fixed unless the package is removed from distribution.
Comment 3 Michael Simacek 2014-03-25 04:57:23 EDT
Created attachment 878347 [details]
Remove version from JAR name
Comment 4 Michael Simacek 2014-03-27 10:23:00 EDT
The original owner didn't assign this, putting back to NEW
Comment 5 Mikolaj Izdebski 2014-03-27 10:31:17 EDT
Fixed in jcharts-0.7.5-12
Comment 6 Mikolaj Izdebski 2014-03-27 10:45:43 EDT
I believe that this bug is fixed in jcharts-0.7.5-12,
which is available in Fedora Rawhide, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=507271

Note You need to log in before you can comment on or make changes to this bug.