Bug 102213 - realvnc doesn't have some of the functionality that tightvnc had (esp. -via)
Summary: realvnc doesn't have some of the functionality that tightvnc had (esp. -via)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: vnc   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-12 16:48 UTC by david d zuhn
Modified: 2007-04-18 16:56 UTC (History)
0 users

Fixed In Version: 4.0-0.beta3.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-02 14:30:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description david d zuhn 2003-08-12 16:48:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
RealVNC provides some useful advantages (notably better speed, at least in
perception), but from a straight translation from tightvnc we lose some
functionality. 

The biggest one was support for -via, which automatically set up the SSH tunnel
for you.

Yes, you can still use RealVNC by setting up the tunnel yourself, but I found
users much more comfortable with -via.

Version-Release number of selected component (if applicable):
vnc-4.0-0.beta3.5.1

How reproducible:
Always

Steps to Reproduce:
1. vncviewer -via gateway internal:1

    

Actual Results:  Syntax error for the new vncviewer

Expected Results:  Connection to a machine name internal's VNC server, via an
ssh tunnel through the machine 'gateway'.

Additional info:

I'm calling this a bug, not an enhancement request, because it's a loss of
functionality as compared to previous releases.  It's not a drop in replacement.

Comment 1 Tim Waugh 2003-08-22 09:35:50 UTC
Please try 4.0-0.beta3.9, which provides a -via option.  It will appear in
rawhide in the next few days.

Comment 2 david d zuhn 2003-08-25 16:20:44 UTC
I have tried the latest rawhide version, and it doesn't correctly handle the
case of using an intermediate gateway to access the destination machine:

In the case of "vncviewer -via gateway internalhost:1", it executed the
following ssh command:

/usr/bin/ssh -f -L 5598:localhost:5901 gateway sleep 20

where I would have expected it to run:

/usr/bin/ssh -f -L 5598:internalhost:5901 gateway sleep 20

(note the use of localhost as opposed to internalhost).  

At many sites, the user will not have the capability to run a VNC server on the
gateway.   

In the vnc-via patch, the SSH tunnelling setup shouldn't hardcode localhost. 
The algorithm should be "if a remote host is specified in the VNC server
argument, use that hostname, otherwise use localhost".  



Comment 3 Tim Waugh 2004-03-02 14:30:51 UTC
I think the current patch does the right thing now.

Comment 4 david d zuhn 2004-03-02 15:13:43 UTC
I agree.  Things are as on the old VNC, in this respect.


Note You need to log in before you can comment on or make changes to this bug.