Bug 1022135 - libphidget: remove versioned jars from %{_javadir}
libphidget: remove versioned jars from %{_javadir}
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libphidget (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rich Mattes
Fedora Extras Quality Assurance
:
Depends On: 1079464
Blocks: 1022024
  Show dependency treegraph
 
Reported: 2013-10-22 11:48 EDT by Stanislav Ochotnicky
Modified: 2014-06-01 14:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-01 14:40:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stanislav Ochotnicky 2013-10-22 11:48:52 EDT
Package libphidget seems to contain versioned jar files in %{_javadir}
(/usr/share/java). Such versioned files cause problems for automatic
requires generation and violate packaging guidelines[1].

List of subpackages and contained versioned jars
libphidget-java:
/usr/share/java/phidget21.jar


There are cases where this can be a false positive. Most likely if:
   * your package is compatibility version and contains only versioned
     jars
   * your package has version in the name of jars that are part of
     package name

Thank you,

[1] https://fedoraproject.org/wiki/Packaging:Java#Filenames
Comment 1 Rich Mattes 2014-04-01 21:59:10 EDT
The name of the jar file matches the name of of the C header and library provided by the package, so I think it's a false positive.  If you disagree, I don't really have a problem changing it.

I'm not a java expert, but it looks like the phidget jar file is implemented using jni, and the native components are embedded in libphidget21.so along with the C api.  Should I be putting phidget21.jar in %{_jnidir} instead of %{_datadir}/java?
Comment 2 Mikolaj Izdebski 2014-04-02 06:04:50 EDT
(In reply to Rich Mattes from comment #1)
> The name of the jar file matches the name of of the C header and library
> provided by the package, so I think it's a false positive.  If you disagree,
> I don't really have a problem changing it.

Most of Java upstreams provide JARs with versions, but in Fedora we still install them with the version stripped (except for few cases, which are explained in the guidelines).

> I'm not a java expert, but it looks like the phidget jar file is implemented
> using jni, and the native components are embedded in libphidget21.so along
> with the C api.  Should I be putting phidget21.jar in %{_jnidir} instead of
> %{_datadir}/java?

Yes, it should go to %{_jnidir}.
Comment 3 Rich Mattes 2014-06-01 14:40:04 EDT
Moved datadir/java/phidget21.jar to jnidir/phidget.jar

Note You need to log in before you can comment on or make changes to this bug.