Bug 1022154 - The dwm-user package does not specify patch as its dependency
The dwm-user package does not specify patch as its dependency
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dwm (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Šabata
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 11:51 EDT by Jaromir Hradilek
Modified: 2014-05-27 09:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-27 09:39:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaromir Hradilek 2013-10-22 11:51:57 EDT
Description of problem:
The dwm-start script uses the patch utility to apply all patches located in the $HOME/.dwm/patches/ directory to the dwm sources before rebuilding the dwm binary, but neither the dwm-user package nor any of its few dependencies require the patch utility to be installed in the system. This may be a problem, because not all Fedora spins install this utility by default (Fedora 19 Xfce Spin does not). As a consequence, an attempt to build the dwm binary on such a system fails with an error.

Version-Release number of selected component (if applicable):
dwm-user-6.0-7.fc19.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Add a patch to the $HOME/.dwm/patchees/ directory and make sure that the dwm binary can be built with it.
2. Remove the patch package.
3. Delete the $HOME/.dwm/dwm binary.
4. Start a new dwm-user session.

Actual results:
Unless there is an older build of the dwm binary in the $HOME/.dwm/ directory, any attempt to start the dwm-user session silently fails.

Expected results:
The dwm-user package should always install the patch utility as a dependency to prevent this error.

Additional info:
None.
Comment 1 Petr Šabata 2013-10-23 00:10:55 EDT
True.  Thanks for the report.
Comment 2 Fedora Update System 2013-10-23 01:17:13 EDT
dwm-6.0-8.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dwm-6.0-8.fc20
Comment 3 Fedora Update System 2013-10-23 01:17:54 EDT
dwm-6.0-8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/dwm-6.0-8.fc19
Comment 4 Fedora Update System 2013-11-02 00:59:41 EDT
dwm-6.0-8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2013-11-10 03:12:32 EST
dwm-6.0-8.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.