Bug 1022186 - rhncfg-manager does not work with FIPS enabled Satellite
rhncfg-manager does not work with FIPS enabled Satellite
Status: CLOSED DUPLICATE of bug 1020895
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
560
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milan Zázrivec
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 12:22 EDT by Milan Zázrivec
Modified: 2013-11-01 13:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-31 13:53:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Zázrivec 2013-10-22 12:22:03 EDT
Description of problem:
rhncfg-manager utility installed on a client registered to a FIPS enabled
Satellite does not work. All operations fail at login:

# rhncfg-manager list-channels
Using server name dhcp-37-127.lab.eng.brq.redhat.com
Username: admin
Password: 
Session error: (1, "While running 'config.rhn_login': caught\n<type 'exceptions.ValueError'> : error:060800A3:digital envelope routines:EVP_DigestInit_ex:disabled for fips\n")

Related server-side error:

Exception Handler Information
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/spacewalk/server/apacheRequest.py", line 123, in call_function
    response = apply(func, params)
  File "/usr/lib/python2.6/site-packages/spacewalk/server/configFilesHandler.py", line 108, in login
    return session.get_session()
  File "/usr/lib/python2.6/site-packages/spacewalk/server/rhnSession.py", line 75, in get_session
    return "%sx%s" % (self.session_id, self.digest())
  File "/usr/lib/python2.6/site-packages/spacewalk/server/rhnSession.py", line 68, in digest
    ctx = hashlib.new('md5')
  File "/usr/lib64/python2.6/hashlib.py", line 83, in __hash_new
    return _hashlib.new(name, string, usedforsecurity)
ValueError: error:060800A3:digital envelope routines:EVP_DigestInit_ex:disabled for fips


Version-Release number of selected component (if applicable):
Satellite 5.6

How reproducible:
Always

Steps to Reproduce:
1. Satellite 5.6 on a FIPS enabled RHEL machine
2. rhncfg-manager ... on a registered client

Actual results:
Above error.

Expected results:
rhncfg-manager works.

Additional info:
N/A
Comment 1 Milan Zázrivec 2013-10-31 13:53:25 EDT

*** This bug has been marked as a duplicate of bug 1020895 ***

Note You need to log in before you can comment on or make changes to this bug.